# Curl can´t connect to dedicated es server :(

**URL:** https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112
**Category:** Elasticsearch
**Created:** [June 15, 2012, 1:26am UTC](https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112 "2012-06-15T01:26:01Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mrblue](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrblue/32/23268_2.png) [@mrblue](https://discuss.elastic.co/u/mrblue)
#### Post date: [June 15, 2012, 1:26am UTC](https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112/1 "2012-06-15T01:26:01Z")

</div>

Hi everybody,

this is kinda strange, i hope you can help !

-\> Elsaticsearch is up and running for weeks without failure on dedicated  
root server with debian 6 "squeeze". As far as i know, there is no firewall  
whatsoever. (checked with iptables -L)  
-\> I can acess it from two different servers, no problems. never configured  
anything  
-\> But i can´t from another server. telnet myserver 80 works fine, but 9200  
is always refused. curl reports error (7) connection refused. Any ideas ?

---

<div class="post-metadata">

### Author: ![calc](https://avatars.discourse-cdn.com/v4/letter/c/ecc23a/32.png) [@calc](https://discuss.elastic.co/u/calc)
#### Post date: [June 15, 2012, 5:34am UTC](https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112/2 "2012-06-15T05:34:41Z")

</div>

If you are running these servers in the cloud, I suspect you'd have to  
explicitly set up rules to allow connection on port 9200.

On Thursday, June 14, 2012 9:26:01 PM UTC-4, mrblue wrote:

> Hi everybody,
> 
> this is kinda strange, i hope you can help !
> 
> -\> Elsaticsearch is up and running for weeks without failure on dedicated  
> root server with debian 6 "squeeze". As far as i know, there is no firewall  
> whatsoever. (checked with iptables -L)  
> -\> I can acess it from two different servers, no problems. never  
> configured anything  
> -\> But i can´t from another server. telnet myserver 80 works fine, but  
> 9200 is always refused. curl reports error (7) connection refused. Any  
> ideas ?

---

<div class="post-metadata">

### Author: ![mrblue](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrblue/32/23268_2.png) [@mrblue](https://discuss.elastic.co/u/mrblue)
#### Post date: [June 15, 2012, 4:07pm UTC](https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112/3 "2012-06-15T16:07:54Z")

</div>

Oh well it turned out that the hoster had a second firewall wich couldn´t  
be configurated on the server.. At least there shoud be _something_ in the  
FAQ. Thx anyway !

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:23am UTC](https://discuss.elastic.co/t/curl-can-t-connect-to-dedicated-es-server/8112/4 "2017-07-06T03:23:53Z")

</div>


