# Custom Cluster name issue

**URL:** <https://discuss.elastic.co/t/custom-cluster-name-issue/9917>\
**Category:** Elasticsearch\
**Created:** [December 3, 2012, 8:21am UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917 "2012-12-03T08:21:32Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mayank](https://avatars.discourse-cdn.com/v4/letter/m/bc8723/32.png) [@Mayank](https://discuss.elastic.co/u/Mayank)\
**Post date:** [December 3, 2012, 8:21am UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917/1 "2012-12-03T08:21:32Z")

</div>

Hi,

I want to give custom cluster name to create index but I am not able to do  
so as after changing the setting in elasticsearch.yml when I tries to start  
the instance it gives me following error as:

[dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...

- SettingsException[Failed to load settings from  
[file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
ParserException[null; expected '', but found  
BlockMappingStart]  
[dmadmin@INDDTMDIDX01 bin]$ ./elasticsearch  
[dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...
- SettingsException[Failed to load settings from  
[file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
ParserException[null; expected '', but found  
BlockMappingStart]  
Can anyone please help me out in this?

Regards,  
Mayank

--

---

<div class="post-metadata">

**Author:** ![Rafal\_Kuc\_3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rafal_kuc_3/32/799_2.png) [@Rafal\_Kuc\_3](https://discuss.elastic.co/u/Rafal_Kuc_3)\
**Post date:** [December 3, 2012, 8:39am UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917/2 "2012-12-03T08:39:51Z")

</div>

Hello!

Could you share your elasticsearch.yml file, because it seems that there is a problem with it.

_--_

Regards,

Rafał Kuć

Sematext :: [http://sematext.com/](http://sematext.com/) _:: Solr - Lucene - Nutch - ElasticSearch_

Hi,

I want to give custom cluster name to create index but I am not able to do so as after changing the setting in elasticsearch.yml when I tries to start the instance it gives me following error as:

[dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...

- SettingsException[Failed to load settings from [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]

[dmadmin@INDDTMDIDX01 bin]$ ./elasticsearch

[dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...

- SettingsException[Failed to load settings from [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]

Can anyone please help me out in this?

Regards,

Mayank

--

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [December 3, 2012, 6:49pm UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917/3 "2012-12-03T18:49:11Z")

</div>

In your elasticsearch.yml, you probably have a line that looks like this:

cluster.name:"some-elasticsearch-cluster-name"

Put space between : and ", so it looks like this:

cluster.name: "some-elasticsearch-cluster-name"

If this doesn't help, please post your elasticsearch.yml file as Rafał has  
already suggested.

On Monday, December 3, 2012 3:21:32 AM UTC-5, Mayank wrote:

> Hi,
> 
> I want to give custom cluster name to create index but I am not able to do  
> so as after changing the setting in elasticsearch.yml when I tries to start  
> the instance it gives me following error as:
> 
> [dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...
> 
> - SettingsException[Failed to load settings from  
> [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
> ParserException[null; expected '', but found  
> BlockMappingStart]  
> [dmadmin@INDDTMDIDX01 bin]$ ./elasticsearch  
> [dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...
> - SettingsException[Failed to load settings from  
> [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
> ParserException[null; expected '', but found  
> BlockMappingStart]  
> Can anyone please help me out in this?
> 
> Regards,  
> Mayank

--

---

<div class="post-metadata">

**Author:** ![Mayank](https://avatars.discourse-cdn.com/v4/letter/m/bc8723/32.png) [@Mayank](https://discuss.elastic.co/u/Mayank)\
**Post date:** [December 4, 2012, 2:04pm UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917/4 "2012-12-04T14:04:22Z")

</div>

Hi Rafal/Igor,

Thanks for the suggestion it worked by reinstalling the instance again with  
the old elasticsearch.yml.

On Tuesday, December 4, 2012 12:19:11 AM UTC+5:30, Igor Motov wrote:

> In your elasticsearch.yml, you probably have a line that looks like this:
> 
> cluster.name:"some-elasticsearch-cluster-name"
> 
> Put space between : and ", so it looks like this:
> 
> cluster.name: "some-elasticsearch-cluster-name"
> 
> If this doesn't help, please post your elasticsearch.yml file as Rafał has  
> already suggested.
> 
> On Monday, December 3, 2012 3:21:32 AM UTC-5, Mayank wrote:
> 
> > Hi,
> > 
> > I want to give custom cluster name to create index but I am not able to  
> > do so as after changing the setting in elasticsearch.yml when I tries to  
> > start the instance it gives me following error as:
> > 
> > [dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...
> > 
> > - SettingsException[Failed to load settings from  
> > [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
> > ParserException[null; expected '', but found  
> > BlockMappingStart]  
> > [dmadmin@INDDTMDIDX01 bin]$ ./elasticsearch  
> > [dmadmin@INDDTMDIDX01 bin]$ {0.19.10}: Setup Failed ...
> > - SettingsException[Failed to load settings from  
> > [file:/dctm/app/elasticsearch-0.19.10\_Second\_Instance/config/elasticsearch.yml]]  
> > ParserException[null; expected '', but found  
> > BlockMappingStart]  
> > Can anyone please help me out in this?
> > 
> > Regards,  
> > Mayank

--

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:01am UTC](https://discuss.elastic.co/t/custom-cluster-name-issue/9917/5 "2017-07-06T03:01:36Z")

</div>


