# Custom Logs integration upgrade fails with invalid\_index\_template\_exception

**URL:** <https://discuss.elastic.co/t/custom-logs-integration-upgrade-fails-with-invalid-index-template-exception/346056>\
**Category:** Elastic Agent\
**Tags:** fleet\
**Created:** [October 30, 2023, 3:53pm UTC](https://discuss.elastic.co/t/custom-logs-integration-upgrade-fails-with-invalid-index-template-exception/346056 "2023-10-30T15:53:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jmartin](https://avatars.discourse-cdn.com/v4/letter/j/b3f665/32.png) [@jmartin](https://discuss.elastic.co/u/jmartin)\
**Post date:** [October 30, 2023, 3:53pm UTC](https://discuss.elastic.co/t/custom-logs-integration-upgrade-fails-with-invalid-index-template-exception/346056/1 "2023-10-30T15:53:07Z")

</div>

When trying to upgrade the custom logs integration, for fleet from version 2.0.0 to 2.3.0.  
Kibana gives the following error:  
` invalid_index_template_exception: index_template [logs-ERMP@custom] invalid, cause [Validation Failed: 1: name must be lower cased;]]`

the index\_template dos not exist but for some reason this integration still references it, It did exist over a year ago and was made by mistake with the uppercase. Is there anyway to remove the reference to this index template so the upgrade can continue? I have ensured there is no component or index template named "logs-ERMP@custom" it seems as if something in the integration is still holding onto the information.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 27, 2023, 3:53pm UTC](https://discuss.elastic.co/t/custom-logs-integration-upgrade-fails-with-invalid-index-template-exception/346056/2 "2023-11-27T15:53:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
