# Dangling Index Errors

**URL:** https://discuss.elastic.co/t/dangling-index-errors/117399
**Category:** Elasticsearch
**Created:** [January 29, 2018, 6:16am UTC](https://discuss.elastic.co/t/dangling-index-errors/117399 "2018-01-29T06:16:19Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![inhinyera16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/inhinyera16/32/61625_2.png) [@inhinyera16](https://discuss.elastic.co/u/inhinyera16)
#### Post date: [January 29, 2018, 6:16am UTC](https://discuss.elastic.co/t/dangling-index-errors/117399/1 "2018-01-29T06:16:19Z")

</div>

I've run the logstash pipeline to index data in my cluster (3 master, data and ingest eligible) and 1 coordinating node. That time, i havent checked that the 2 nodes (not coordinating nodes) are down and this throws an error in on of my master eligible node. Can somebody explain this to me? Dont know what happened then.

```
[2018-01-29T01:05:46,720][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.28/PEjyYoG7QX2zZUI-6Zje9w]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,720][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.29/Xl0QHudSTBCWlkFgLBnCkw]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,720][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.27/ZGKsyR7GTZW121KfQvVTuQ]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,947][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.28/PEjyYoG7QX2zZUI-6Zje9w]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,947][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.29/Xl0QHudSTBCWlkFgLBnCkw]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,947][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.27/ZGKsyR7GTZW121KfQvVTuQ]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,957][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.28/PEjyYoG7QX2zZUI-6Zje9w]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,957][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.29/Xl0QHudSTBCWlkFgLBnCkw]] can not be imported as a dangling index, as index with same name already exists in cluster metadata
[2018-01-29T01:05:46,957][WARN][o.e.g.DanglingIndicesState] [s6PcSrU] [[metricbeat-6.1.1-2018.01.27/ZGKsyR7GTZW121KfQvVTuQ]] can not be imported as a dangling index, as index with same name already exists in cluster metadata

```

Btw i used elasticsearch v 6.1.1

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [January 29, 2018, 8:28am UTC](https://discuss.elastic.co/t/dangling-index-errors/117399/2 "2018-01-29T08:28:00Z")

</div>

Hey,

the docs might help here, [https://www.elastic.co/guide/en/elasticsearch/reference/master/\_dangling\_indices.html](https://www.elastic.co/guide/en/elasticsearch/reference/master/_dangling_indices.html)

--Alex

---

<div class="post-metadata">

### Author: ![inhinyera16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/inhinyera16/32/61625_2.png) [@inhinyera16](https://discuss.elastic.co/u/inhinyera16)
#### Post date: [January 29, 2018, 2:14pm UTC](https://discuss.elastic.co/t/dangling-index-errors/117399/3 "2018-01-29T14:14:52Z")

</div>

The site seems not straightforward of why it happened.  
Anyways, i resolved it by deleting the node directories.

Thanks!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 26, 2018, 2:14pm UTC](https://discuss.elastic.co/t/dangling-index-errors/117399/4 "2018-02-26T14:14:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
