# 一部のDashboardでPDF Reportが失敗する

**URL:** <https://discuss.elastic.co/t/dashboard-pdf-report/205972>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [October 31, 2019, 4:31am UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972 "2019-10-31T04:31:24Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sshota](https://avatars.discourse-cdn.com/v4/letter/s/f9ae1b/32.png) [@sshota](https://discuss.elastic.co/u/sshota)\
**Post date:** [October 31, 2019, 4:31am UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972/1 "2019-10-31T04:31:24Z")

</div>

お世話になります。

一部のDashboardでPDF Reportが失敗します。  
成功するDashboardもあるので基本的な設定ができていないわけではないと思っています。

エラーメッセージとして、_ **ERR\_CONNECTION\_TIMED\_OUT** _ が表示されていました。  
この解決策として、_ **xpack.reporting.queue.timeout** _ の設定を600000に設定してみたのですが、  
設定が効いていないように見えます。

Dashboard → PDF Report → Generate PDFボタン押下から、画面右下に失敗のポップアップがでるまでの時間をあくまで画面表示ベースですが計測したところ、  
_ **xpack.reporting.queue.timeout** _ のデフォルト値の120000（2分）前後で失敗となるようです。

設定方法などに誤りはありますでしょうか。  
原因、解決策などご教示いただけますと幸いです。

## エラーメッセージ

_ **ERR\_CONNECTION\_TIMED\_OUT** _

 ![unable%20to%20generate%20report](https://us1.discourse-cdn.com/elastic/original/3X/b/b/bbf1b6e2a07b719ed58542a8f8c0405261c24d8e.jpeg)

## 動作環境

- Elasticsearch 7.3.0 (on Elastic Cloud)
- Kibana 7.3.0 (on nginx - EC2(Ubuntu 16.04 LTS) )

## kibana.yml（抜粋）

xpack.reporting.encryptionKey: "my\_encryptionKey"  
xpack.reporting.queue.timeout: 600000  
xpack.reporting.kibanaServer.port: 80  
xpack.reporting.kibanaServer.protocol: http  
xpack.reporting.kibanaServer.hostname: "my\_domain"  
xpack.reporting.kibanaApp: "/app/kibana"

## 補足

- ごくまれにですが、下記エラーで失敗する事もあります。原因がわかりません。  
_**Error: Unable to spawn Chromium: [Error: Page crashed!]**_  
 ![unable%20to%20generate%20report2](https://us1.discourse-cdn.com/elastic/original/3X/8/a/8a886323337d8fa1e28dd41e4fba35735a1f3996.jpeg)
- 上記EC2上のKibanaのほかに、Elatic Cloud上でもKibanaを動作させていますが、下記設定は同様に入れております。  
xpack.reporting.encryptionKey: "my\_encryptionKey"  
xpack.reporting.queue.timeout: 600000

---

<div class="post-metadata">

**Author:** ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)\
**Post date:** [November 2, 2019, 12:59pm UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972/2 "2019-11-02T12:59:56Z")

</div>

特に回答を持ち合わせているわけではないですが、1点確認させてください。

PDF Reportが失敗するのは、動作環境にある EC2上に構築したnginx経由のKibanaのときだけでしょうか？  
それとも、直接Elastic CloudのKibanaを操作したときでも、当該ダッシュボードのReportは同じように失敗するのでしょうか？

もし、後者のElastic Cloudでも起きるということであれば、Elastic Cloudのサポートに問い合わせもできるのかな？と思いました。

---

<div class="post-metadata">

**Author:** ![sshota](https://avatars.discourse-cdn.com/v4/letter/s/f9ae1b/32.png) [@sshota](https://discuss.elastic.co/u/sshota)\
**Post date:** [November 5, 2019, 3:01am UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972/3 "2019-11-05T03:01:35Z")

</div>

ご回答ありがとうございます。

> PDF Reportが失敗するのは、動作環境にある EC2上に構築したnginx経由のKibanaのときだけでしょうか？  
> それとも、直接Elastic CloudのKibanaを操作したときでも、当該ダッシュボードのReportは同じように失敗するのでしょうか？

EC2上のKibanaでもElastic CloudのKibanaから操作したときでも、ともにPDF Reportが失敗します。

以前、複数のKibanaからのアクセスがある場合に、xpack.reporting.～～の設定は、全てのKibanaで設定しないと、挙動がおかしくなる(PDF ReportをしないKibanaにも設定をする必要がある)ということを聞いたことがあるのですが、EC2上のKibanaの設定はおかしいところはありませんでしょうか。

おかしいところがなければ、一度Elastic Cloudのサポートに問い合わせすることも検討したいと思います。

---

<div class="post-metadata">

**Author:** ![sshota](https://avatars.discourse-cdn.com/v4/letter/s/f9ae1b/32.png) [@sshota](https://discuss.elastic.co/u/sshota)\
**Post date:** [November 6, 2019, 2:04am UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972/4 "2019-11-06T02:04:16Z")

</div>

解決いたしました。

どうやら、リソース不足が原因だったようです。  
EC2のインスタンスタイプも、Elastic CloudのKibanaのリソース割り当ても、  
どちらもほぼ最小構成で動かしていたために発生していたようです。

該当環境をスケールアップすることで、問題なくPDF Reportすることができました。

ご回答頂きありがとうございました。  
お騒がせしました。

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 4, 2019, 2:04am UTC](https://discuss.elastic.co/t/dashboard-pdf-report/205972/5 "2019-12-04T02:04:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
