# Dashboard setup fails: Unable to bulk\_create index-pattern

**URL:** <https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007>\
**Category:** Beats\
**Tags:** filebeat, metricbeat\
**Created:** [December 15, 2021, 3:40pm UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007 "2021-12-15T15:40:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Adriann](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adriann/32/77780_2.png) [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Post date:** [December 15, 2021, 3:40pm UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/1 "2021-12-15T15:40:17Z")

</div>

Hello,

I have encountered the same problem as the user in [this](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/287524) post.

I configured metricbeat and filebeat with the kibana\_system user. Should I create a new user that runs as a kibana\_system user and add some rights? Which if so?

The template has been set up correctly but the dashboard does not want to work.

I am on ELK and KIB ver 7.16

---

<div class="post-metadata">

**Author:** ![gunlomboy](https://avatars.discourse-cdn.com/v4/letter/g/c0e974/32.png) [@gunlomboy](https://discuss.elastic.co/u/gunlomboy)\
**Post date:** [December 15, 2021, 4:09pm UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/2 "2021-12-15T16:09:37Z")

</div>

Hi

I finally resolved my issue by temporarily changing the user to "elastic" with the necessary password (or any user with superuser permissions) then running the agent again with the -setup option.

---

<div class="post-metadata">

**Author:** ![Adriann](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adriann/32/77780_2.png) [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Post date:** [December 15, 2021, 4:11pm UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/3 "2021-12-15T16:11:27Z")

</div>

Hi,

I have done that on the test server but do not want to be forced to do this on production.

---

<div class="post-metadata">

**Author:** ![Adriann](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adriann/32/77780_2.png) [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Post date:** [December 16, 2021, 8:46am UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/4 "2021-12-16T08:46:23Z")

</div>

I have made a new user. Gave privilege inherit from the elastic user but still the same outcome.

---

<div class="post-metadata">

**Author:** ![Adriann](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adriann/32/77780_2.png) [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Post date:** [December 16, 2021, 9:07am UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/5 "2021-12-16T09:07:46Z")

</div>

I was missing "kibana\_admin" inheritance. Not it works.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 13, 2022, 11:08am UTC](https://discuss.elastic.co/t/dashboard-setup-fails-unable-to-bulk-create-index-pattern/292007/6 "2022-01-13T11:08:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
