# Data nodes are not able to join master node and failed to make a cluster

**URL:** <https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657>\
**Category:** Elasticsearch\
**Created:** [September 7, 2018, 5:57am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657 "2018-09-07T05:57:46Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 5:57am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/1 "2018-09-07T05:57:47Z")

</div>

Hi All,

I have created elasticsearch cluster beofre and it is working fine without any issue with the same configuration as given below. But I am not sure  
why I am getting message "not enough master nodes discovered during pinging (found [[]], but needed [1])," while creating a new cluster having new  
servers and nodes are not able to join the master node. I am fed up with this issue so I am asking for your help. Please let me know what I am doing wrong here.

Master Node -  
cluster.name: cluster\_dashbaord  
node.name: ${HOSTNAME}  
node.master: true  
node.data: false  
path.data: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/data  
path.logs: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/logs  
discovery.zen.ping.unicast.hosts: ["10.182.197.100","10.182.197.101","10.182.197.102"]  
bootstrap.system\_call\_filter: false  
action.auto\_create\_index: ".security\*,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*,.ml\*"  
network.host: 0.0.0.0  
transport.tcp.compress: true  
http.port : 9400  
transport.tcp.port: 9500  
discovery.zen.minimum\_master\_nodes: 1  
network.publish\_host: 0.0.0.0  
network.bind\_host: 0.0.0.0

Data Node 1 -  
cluster.name: cluster\_dashbaord  
node.name: ${HOSTNAME}  
node.master: false  
node.data: true  
path.data: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/data  
path.logs: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/logs  
discovery.zen.ping.unicast.hosts: ["10.182.197.100","10.182.197.101","10.182.197.102"]  
bootstrap.system\_call\_filter: false  
action.auto\_create\_index: ".security\*,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*,.ml\*"  
network.host: 0.0.0.0  
transport.tcp.compress: true  
http.port : 9400  
transport.tcp.port: 9500  
discovery.zen.minimum\_master\_nodes: 1  
network.publish\_host: 0.0.0.0

Data Node2 -  
cluster.name: cluster\_dashbaord  
node.name: ${HOSTNAME}  
node.master: false  
node.data: true  
path.data: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/data  
path.logs: /var/fpwork/workspace\_smtrs/elasticsearch-6.4.0/logs  
discovery.zen.ping.unicast.hosts: ["10.182.197.100","10.182.197.101","10.182.197.102"]  
bootstrap.system\_call\_filter: false  
action.auto\_create\_index: ".security\*,.monitoring\*,.watches,.triggered\_watches,.watcher-history\*,.ml\*"  
network.host: 0.0.0.0  
transport.tcp.compress: true  
http.port : 9400  
transport.tcp.port: 9500  
discovery.zen.minimum\_master\_nodes: 1  
network.publish\_host: 0.0.0.0

# Console Snapshot

[2018-09-07T00:30:46,305][WARN][o.e.d.z.ZenDiscovery] [tr\_cloud2] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again  
[2018-09-07T00:30:49,306][WARN][o.e.d.z.ZenDiscovery] [tr\_cloud2] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again  
[2018-09-07T00:30:52,307][WARN][o.e.d.z.ZenDiscovery] [tr\_cloud2] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again  
[2018-09-07T00:30:55,297][WARN][o.e.n.Node] [tr\_cloud2] timed out while waiting for initial discovery state - timeout: 30s[2018-09-07T00:30:55,308][WARN][o.e.d.z.ZenDiscovery] [trs\_cloud2] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again  
[2018-09-07T00:30:55,315][INFO][o.e.x.s.t.n.SecurityNetty4HttperverTransport] [trs\_cloud2] publish\_address {192.168.0.37:9400}, bound\_addresses {[::]:9400}  
[2018-09-07T00:30:55,316][INFO][o.e.n.Node] [tr\_cloud2] started[2018-09-07T00:30:58,309][WARN][o.e.d.z.ZenDiscovery] [trs\_cloud2] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 6:58am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/2 "2018-09-07T06:58:24Z")

</div>

@dadoonet Can you please help me. I am totally frustrated with this issue and not able to find out the problem.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 7, 2018, 8:07am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/3 "2018-09-07T08:07:56Z")

</div>

As you have used a non-default transport port (9500), you need to include the port number in the unicast host list. I would also recommend making all node master eligible and setting `minimum_master_nodes` to `2` in order to improve stability and resilience.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [September 7, 2018, 8:18am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/4 "2018-09-07T08:18:11Z")

</div>

Yeah. Use:

```auto
discovery.zen.ping.unicast.hosts: ["10.182.197.100:9500","10.182.197.101:9500","10.182.197.102:9500"]

```

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 8:55am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/5 "2018-09-07T08:55:23Z")

</div>

@Christian_Dahlqvist When I changed the minimum\_master\_nodes to 2 and with below config discovery.zen.ping.unicast.hosts: ["10.182.197.102:9500","10.182.197.132:9500","10.182.197.160:9500"] I am getting below given error.

[2018-09-07T14:22:35,361][WARN][o.e.d.z.ZenDiscovery] [-scrum] not enough master nodes discovered during pinging (found [[Candidate{node={vikrant-scrum}{ixDYsLpQQzyn-30o4j4iXA}{d4jAeq96Tk-1G8FM4aOCUw}{192.168.0.37}{192.168.0.37:9500}{ml.machine\_memory=67560501248, xpack.installed=true, ml.max\_open\_jobs=20, ml.enabled=true}, clusterStateVersion=-1}]], but needed [2]), pinging again  
[2018-09-07T14:22:38,362][WARN][o.e.d.z.ZenDiscovery] [-scrum] not enough master nodes discovered during pinging (found [[Candidate{node={vikrant-scrum}{ixDYsLpQQzyn-30o4j4iXA}{d4jAeq96Tk-1G8FM4aOCUw}{192.168.0.37}{192.168.0.37:9500}{ml.machine\_memory=67560501248, xpack.installed=true, ml.max\_open\_jobs=20, ml.enabled=true}, clusterStateVersion=-1}]], but needed [2]), pinging again  
[2018-09-07T14:22:41,363][WARN][o.e.d.z.ZenDiscovery] [-scrum] not enough master nodes discovered during pinging (found [[Candidate{node={vikrant-scrum}{ixDYsLpQQzyn-30o4j4iXA}{d4jAeq96Tk-1G8FM4aOCUw}{192.168.0.37}{192.168.0.37:9500}{ml.machine\_memory=67560501248, xpack.installed=true, ml.max\_open\_jobs=20, ml.enabled=true}, clusterStateVersion=-1}]], but needed [2]), pinging again

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 7, 2018, 8:56am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/6 "2018-09-07T08:56:25Z")

</div>

Did you make all your nodes master-eligible (`node.master: true`) as well?

`

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 8:58am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/7 "2018-09-07T08:58:01Z")

</div>

Yes I did.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 7, 2018, 9:02am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/8 "2018-09-07T09:02:08Z")

</div>

Are there any firewall rules in place that prevents the nodes to connect to port 9500 on the other hosts? Test this by logging into one of the hosts and then telnet to port 9500 on the others.

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 9:02am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/9 "2018-09-07T09:02:58Z")

</div>

Configuration with minimum\_master\_nodes to 1 and below configuration.  
discovery.zen.ping.unicast.hosts: ["10.182.197.100:9500","10.182.197.101:9500","10.182.197.102:9500"]. I am still facing the same issue. Please suggest

Console Ouput -  
[2018-09-07T14:29:29,082][INFO][o.e.n.Node] [-scrum] starting ...  
[2018-09-07T14:29:29,216][INFO][o.e.t.TransportService] [-scrum] publish\_address {192.168.0.37:9500}, bound\_addresses {[::]:9500}  
[2018-09-07T14:29:29,229][INFO][o.e.b.BootstrapChecks] [-scrum] bound or publishing to a non-loopback address, enforcing bootstrap checks  
[2018-09-07T14:29:32,249][WARN][o.e.d.z.ZenDiscovery] [-scrum] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again  
[2018-09-07T14:29:35,250][WARN][o.e.d.z.ZenDiscovery] [-scrum] not enough master nodes discovered during pinging (found [[]], but needed [1]), pinging again

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 7, 2018, 9:04am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/10 "2018-09-07T09:04:05Z")

</div>

Please verify that there are no network or connectivity issues.

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 9:07am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/11 "2018-09-07T09:07:02Z")

</div>

I have tried doing telnet with port 9500 but failed now but previously telnet was fine and at that time also I was facing the same issue. How to solve this telnet issue by stopping firewall ?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 7, 2018, 9:12am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/12 "2018-09-07T09:12:27Z")

</div>

That depends on your operating system and how it is set up, so I do not think I can help there.

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 9:17am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/13 "2018-09-07T09:17:06Z")

</div>

I am running Elastic on RHEL.

---

<div class="post-metadata">

**Author:** ![dhananjay88](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@dhananjay88](https://discuss.elastic.co/u/dhananjay88)\
**Post date:** [September 7, 2018, 9:21am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/14 "2018-09-07T09:21:39Z")

</div>

Whenever I am changing port to 9200 and 9300 it is giving below error and not able to find the root cause.  
http.port : 9200  
transport.tcp.port: 9300

Console Log-  
[2018-09-07T14:41:52,662][WARN][o.e.d.z.ZenDiscovery] [-scrum] failed to connect to master [{dhananjay-test-1}{OcBKCmBZQy2nZvFoaG7p7A}{QL0sGP3vQhG8KGWmA3RUdw}{192.168.0.48}{192.168.0.48:9300}{ml.machine\_memory=25284042752, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true}], retrying...  
org.elasticsearch.transport.ConnectTransportException: [dhananjay-test-1][192.168.0.48:9300] connect\_exception  
at org.elasticsearch.transport.TcpChannel.awaitConnected(TcpChannel.java:165) ~[elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.transport.TcpTransport.openConnection(TcpTransport.java:643) ~[elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.transport.TcpTransport.connectToNode(TcpTransport.java:542) ~[elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:329) ~[elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:316) ~[elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.discovery.zen.ZenDiscovery.joinElectedMaster(ZenDiscovery.java:507) [elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.discovery.zen.ZenDiscovery.innerJoinCluster(ZenDiscovery.java:475) [elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.discovery.zen.ZenDiscovery.access$2500(ZenDiscovery.java:88) [elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.discovery.zen.ZenDiscovery$JoinThreadControl$1.run(ZenDiscovery.java:1245) [elasticsearch-6.4.0.jar:6.4.0]  
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:624) [elasticsearch-6.4.0.jar:6.4.0]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0\_171]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0\_171]  
at java.lang.Thread.run(Thread.java:748) [?:1.8.0\_171]  
Caused by: io.netty.channel.AbstractChannel$AnnotatedNoRouteToHostException: No route to host: 192.168.0.48/192.168.0.48:9300

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 5, 2018, 9:21am UTC](https://discuss.elastic.co/t/data-nodes-are-not-able-to-join-master-node-and-failed-to-make-a-cluster/147657/15 "2018-10-05T09:21:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
