# DatabaseError: driver.new.connect returned nil \>\> Logstash doesn´t connect to Postgresql Database

**URL:** https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288
**Category:** Logstash
**Tags:** docker
**Created:** [April 26, 2021, 6:40pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288 "2021-04-26T18:40:28Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Eng.Lucy](https://avatars.discourse-cdn.com/v4/letter/e/7cd45c/32.png) [@Eng.Lucy](https://discuss.elastic.co/u/Eng.Lucy)
#### Post date: [April 26, 2021, 6:40pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288/1 "2021-04-26T18:40:28Z")

</div>

I try to connect Logstash to Postgresql. This database is located in a remote server and Logstash runs in a docker container. My logstash.conf is:  
#  
input{  
jdbc{  
jdbc\_connection\_string =\> "jdbc:postgresql://000.00.00.00:000"  
jdbc\_driver\_library =\> "/usr/share/logstash/postgresql-42.2.19.jar"  
jdbc\_user =\> "user"  
jdbc\_password =\> "password"  
jdbc\_driver\_class =\> "org.postgresql.Driver"  
statement =\> "SELECT _from table"  
schedule =\> "_ \* \* \* \* UTC"  
}  
}

```
    filter{
      split{
        field => "results"
      }
    }

    output{
      elasticsearch{
         hosts => "elasticsearch:9200"
         index => "teste2"
      }
      stdout {}
    }

```

The error that´s occurring is:  
[ERROR][logstash.inputs.jdbc][main] Unable to connect to database. Tried 1 times {:error\_message=\>"Sequel::DatabaseError: driver.new.connect returned nil: probably bad JDBC connection string"}  
{ rufus-scheduler intercepted an error:  
job:  
Rufus::Scheduler::CronJob "\* \* \* \* \* UTC" {}  
error:  
2162  
Sequel::DatabaseConnectionError  
Sequel::DatabaseError: driver.new.connect returned nil: probably bad JDBC connection string  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/adapters/jdbc.rb:240:in `connect' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/connection_pool.rb:122:in `make\_new'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/connection\_pool/threaded.rb:209:in `assign_connection' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/connection_pool/threaded.rb:139:in `acquire'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/connection\_pool/threaded.rb:91:in `hold' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/database/connecting.rb:269:in `synchronize'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/database/connecting.rb:278:in `test_connection' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/database/misc.rb:169:in `initialize'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/database/connecting.rb:57:in `connect' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.41.0/lib/sequel/core.rb:124:in `connect'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:114:in `block in jdbc_connect' org/jruby/RubyKernel.java:1442:in `loop'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:111:in `jdbc_connect' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/jdbc.rb:139:in `open\_jdbc\_connection'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:197:in `execute_statement /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:316:in `execute\_query'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:279:in `block in run' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:234:in `do\_call'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:258:in `do_trigger' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:300:in `block in start\_work\_thread'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:299:in `block in start_work_thread' org/jruby/RubyKernel.java:1442:in `loop'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/rufus-scheduler-3.0.9/lib/rufus/scheduler/jobs.rb:289:in `block in start\_work\_thread'  
tz:  
ENV['TZ']:  
Time.now: 2021-04-26 17:15:00 UTC  
scheduler:  
object\_id: 2056  
opts:  
{:max\_work\_threads=\>1}  
frequency: 0.3  
scheduler\_lock: #Rufus::Scheduler::NullLock:0x483e10bf  
trigger\_lock: #Rufus::Scheduler::NullLock:0x13eb4132  
uptime: 3153.372394 (52m33s372)  
down?: false  
threads: 2  
thread: #Thread:0x4fa42b3e  
thread\_key: rufus\_scheduler\_2056  
work\_threads: 1  
active: 1  
vacant: 0  
max\_work\_threads: 1  
mutexes: {}  
jobs: 1  
at\_jobs: 0  
in\_jobs: 0  
every\_jobs: 0  
interval\_jobs: 0  
cron\_jobs: 1  
running\_jobs: 1  
work\_queue: 0

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [April 26, 2021, 7:24pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288/2 "2021-04-26T19:24:58Z")

</div>

> [@Eng.Lucy](#):
>
> driver.new.connect returned nil: probably bad JDBC connection string

Are you certain your connection string is valid? The one you show is not, but I assume that is because you have redacted the ip address and port number from the actual string.

---

<div class="post-metadata">

### Author: ![ggio](https://avatars.discourse-cdn.com/v4/letter/g/51bf81/32.png) [@ggio](https://discuss.elastic.co/u/ggio)
#### Post date: [April 26, 2021, 7:59pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288/3 "2021-04-26T19:59:26Z")

</div>

> [@Eng.Lucy](#):
>
> jdbc\_connection\_string =\> "jdbc:postgresql://000.00.00.00:000"

The error you are getting seems to be related to a bad jdbc connection string.  
Try with a connection string like this:  
`jdbc:postgresql://host:port/databasename`

---

<div class="post-metadata">

### Author: ![Eng.Lucy](https://avatars.discourse-cdn.com/v4/letter/e/7cd45c/32.png) [@Eng.Lucy](https://discuss.elastic.co/u/Eng.Lucy)
#### Post date: [May 17, 2021, 4:39pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288/4 "2021-05-17T16:39:02Z")

</div>

Thanks.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 14, 2021, 4:39pm UTC](https://discuss.elastic.co/t/databaseerror-driver-new-connect-returned-nil-logstash-doesn-t-connect-to-postgresql-database/271288/5 "2021-06-14T16:39:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
