# Datafeed is encountering errors extracting data

**URL:** https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064
**Category:** Elasticsearch
**Created:** [July 13, 2017, 5:51pm UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064 "2017-07-13T17:51:55Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Lean](https://avatars.discourse-cdn.com/v4/letter/l/ac91a4/32.png) [@Lean](https://discuss.elastic.co/u/Lean)
#### Post date: [July 13, 2017, 5:51pm UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/1 "2017-07-13T17:51:55Z")

</div>

Hello all,

I created an advanced job in ML to analyze low\_varp anomalies over AZ and EL fields of a sat dish. This is supposed -as far as I understood the concept- to give me a measure of anomalies if variance is lower than normal, which is exactly what we need.

Unfortunately as soon as job runs and takes data, an IllegalArgumentException is raised, complaining that "Fielddata is disabled on text fields by default. Set fielddata=true on [antenna] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."

Of course I started looking for keyword fields to solve the problem.  
What is intriguing to me is that I could not select "antenna.keyword" field to configure job: the only field that appears is the non-keyword counterpart, even though logstash already added it in ES index pattern config.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/7/c/7c501e081b80d0d791dec5f8090b7274aaff1198.png)

Are there any settings I overlooked or "rookie" mistakes in my job config? (please see image).

Thanks again!  
Leandro.

---

<div class="post-metadata">

### Author: ![dkyle](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkyle/32/59114_2.png) [@dkyle](https://discuss.elastic.co/u/dkyle)
#### Post date: [July 14, 2017, 9:08am UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/2 "2017-07-14T09:08:42Z")

</div>

Hi Leandro,

In the 5.5 release you can select a `.keyword` field. If you can upgrade to the latest release you will be able to use that job configuration.

---

<div class="post-metadata">

### Author: ![Lean](https://avatars.discourse-cdn.com/v4/letter/l/ac91a4/32.png) [@Lean](https://discuss.elastic.co/u/Lean)
#### Post date: [July 17, 2017, 7:31pm UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/3 "2017-07-17T19:31:46Z")

</div>

Thanks David.

I upgraded from previous (5.4.1) to latest release in order to be able to use .keyword fields.

Since the upgrade, now monitoring screen gives "Error 404 Not Found: undefined" error as attached.

Is this something to do with previous monitoring indices saved with old version?

 ![](https://us1.discourse-cdn.com/elastic/original/3X/f/a/fa7a361c49fc93576126cf46d882d24b3c72a2de.png)

Also, in syslog I found this repetitive message:

> Unhandled rejection [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } } :: {"path":"/\_xpac  
> at respond (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:295:15)  
> at checkRespForFailure (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:254:7)  
> at HttpConnector. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/connectors/http.js:159:7)  
> at IncomingMessage.bound (/usr/share/kibana/node\_modules/elasticsearch/node\_modules/lodash/dist/lodash.js:729:21)  
> at emitNone (events.js:91:20)  
> at IncomingMessage.emit (events.js:185:7)  
> at endReadableNT (\_stream\_readable.js:974:12)  
> at \_combinedTickCallback (internal/process/next\_tick.js:80:11)  
> at process.\_tickDomainCallback (internal/process/next\_tick.js:128:9)

I reset all users again, as I had to reinstall x-packs in every cluster node, and reinstall kibana itself.

Do you guys prefer this to be saved into a new post?

Thank you!  
Leandro.

---

<div class="post-metadata">

### Author: ![dkyle](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkyle/32/59114_2.png) [@dkyle](https://discuss.elastic.co/u/dkyle)
#### Post date: [July 18, 2017, 8:29am UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/4 "2017-07-18T08:29:45Z")

</div>

Hi Leandro,

Yes could you move this to a new post in X-Pack discuss please.

---

<div class="post-metadata">

### Author: ![Lean](https://avatars.discourse-cdn.com/v4/letter/l/ac91a4/32.png) [@Lean](https://discuss.elastic.co/u/Lean)
#### Post date: [July 18, 2017, 11:43am UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/5 "2017-07-18T11:43:07Z")

</div>

Yes, sure.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 15, 2017, 11:43am UTC](https://discuss.elastic.co/t/datafeed-is-encountering-errors-extracting-data/93064/6 "2017-08-15T11:43:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
