# DBG Harvester for file is still running + Solution

**URL:** <https://discuss.elastic.co/t/dbg-harvester-for-file-is-still-running-solution/104223>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 17, 2017, 10:29am UTC](https://discuss.elastic.co/t/dbg-harvester-for-file-is-still-running-solution/104223 "2017-10-17T10:29:30Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jinojoseph](https://avatars.discourse-cdn.com/v4/letter/j/9f8e36/32.png) [@jinojoseph](https://discuss.elastic.co/u/jinojoseph)\
**Post date:** [October 17, 2017, 10:29am UTC](https://discuss.elastic.co/t/dbg-harvester-for-file-is-still-running-solution/104223/1 "2017-10-17T10:29:30Z")

</div>

I had been getting the error like below in my filebeat log:

2017-10-17T04:35:19-05:00 DBG Check file for harvesting: /var/log/secure  
2017-10-17T04:35:19-05:00 DBG Update existing file for harvesting: /var/log/secure, offset: 60739  
2017-10-17T04:35:19-05:00 DBG Harvester for file is still running: /var/log/secure

I have searched in this forum and in a thread it is mentioned to update the logstash plugins and that fixed the issue.

I have updated the plugins using the below command:

> bin/logstash-plugin update

But that doesn't solved the issue and later I figured out that a simple typo mistake like adding a " in the filebeat.yml configuration file can trigger this error.

So I closely checked and in my case it was uncommenting the ssl.certificate\_authorities line in the filebeat configuration.

So decided to post this topic to make all of you aware that commenting the ssl parameter or just a " in the end of any log file might have trigger this error.

Cheers,  
Jino Joseph.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 14, 2017, 10:29am UTC](https://discuss.elastic.co/t/dbg-harvester-for-file-is-still-running-solution/104223/2 "2017-11-14T10:29:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
