# DeadLetterQueue Plugin Error

**URL:** <https://discuss.elastic.co/t/deadletterqueue-plugin-error/175289>\
**Category:** Logstash\
**Created:** [April 4, 2019, 12:00am UTC](https://discuss.elastic.co/t/deadletterqueue-plugin-error/175289 "2019-04-04T00:00:01Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Karthik\_Ramachandran](https://avatars.discourse-cdn.com/v4/letter/k/f19dbf/32.png) [@Karthik\_Ramachandran](https://discuss.elastic.co/u/Karthik_Ramachandran)\
**Post date:** [April 4, 2019, 12:00am UTC](https://discuss.elastic.co/t/deadletterqueue-plugin-error/175289/1 "2019-04-04T00:00:01Z")

</div>

Whenever the logstash is restarted, getting plugin error as below

23:46:27.262 [[main]\<dead\_letter\_queue] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::DeadLetterQueue path=\>"/var/log/logstash/deadletter", commit\_offsets=\>true, pipeline\_id=\>"-------", id=\>"--------", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_56afa592-a052-4899-b8d7-32ba2a094fbc", enable\_metric=\>true, charset=\>"UTF-8"\>\>  
Error: Invalid file. check version  
Exception: Java::JavaLang::RuntimeException  
Stack: org.logstash.common.io.RecordIOReader.(org/logstash/common/io/RecordIOReader.java:59)  
org.logstash.common.io.DeadLetterQueueReader.pollEntryBytes(org/logstash/common/io/DeadLetterQueueReader.java:126)  
org.logstash.common.io.DeadLetterQueueReader.pollEntry(org/logstash/common/io/DeadLetterQueueReader.java:97)  
org.logstash.input.DeadLetterQueueInputPlugin.run(org/logstash/input/DeadLetterQueueInputPlugin.java:82)  
java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)  
org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:423)  
org.jruby.javasupport.JavaMethod.invokeDirect(org/jruby/javasupport/JavaMethod.java:290)  
RUBY.run(/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-input-dead\_letter\_queue-1.1.4/lib/logstash/inputs/dead\_letter\_queue.rb:60)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.invokeOther8:run(usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:514)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.inputworker(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:514)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.invokeOther0:inputworker(usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:507)  
usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.block in start\_input(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:507)  
org.jruby.RubyProc.call(org/jruby/RubyProc.java:289)  
org.jruby.RubyProc.call(org/jruby/RubyProc.java:246)  
java.lang.Thread.run(java/lang/Thread.java:748)  
23:46:27.422 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] INFO logstash.pipeline - Starting pipeline {:pipeline\_id=\>"--------", "pipeline.workers"=\>1, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50}

Tried to enable DEBUG logs for "org.logstash.common.io.DeadLetterQueueReader", but not debug entries are found. Not sure if my log4J settings are correct. Also, not able to identify the cause of issue.

cat log4j2.properties  
logger.DeadLetterQueueReader.name = org.logstash.common.io.DeadLetterQueueReader  
logger.DeadLetterQueueReader.level = debug

I have detailed various scenarios on the same issue in the thread [Logstash Error - Deadletter queue/plugin - troubleshooting](https://discuss.elastic.co/t/logstash-error-deadletter-queue-plugin-troubleshooting/160250/3) but no response ☹

Any guidance around the issue would be helpful.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 2, 2019, 12:00am UTC](https://discuss.elastic.co/t/deadletterqueue-plugin-error/175289/2 "2019-05-02T00:00:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
