# DEBIAN - Problème lancement Elasticsearch

**URL:** <https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483>\
**Category:** Discussions en français\
**Created:** [November 26, 2019, 11:03am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483 "2019-11-26T11:03:16Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Theo\_Meteyer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo_meteyer/32/58352_2.png) [@Theo\_Meteyer](https://discuss.elastic.co/u/Theo_Meteyer)\
**Post date:** [November 26, 2019, 11:03am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483/1 "2019-11-26T11:03:17Z")

</div>

Bonjour,  
Je viens vous demander de l'aide car depuis plusieurs jours de rencontre un soucis avec Elasticsearch..  
Je ne suis pas très familier avec Debian, et donc la question pourrait sembler stupide.  
Pour mes études, je suis chargé de faire un serveur Graylog qui analysera des logs. Le soucis est que mon Graylog ne récupère aucune information de mon serveur Debian.  
J'ai donc fait un "service elasticsearch status" et obtiens :

```auto
root@debian:~# service elasticsearch status
â elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2019-11-26 11:50:41 CET; 52s ago
     Docs: http://www.elastic.co
  Process: 1410 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 1410 (code=exited, status=1/FAILURE)

nov. 26 11:50:23 debian systemd[1]: Started Elasticsearch.
nov. 26 11:50:23 debian elasticsearch[1410]: warning: Falling back to java on path. This behavior is deprecated. Specify JAVA_HOME
nov. 26 11:50:41 debian systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
nov. 26 11:50:41 debian systemd[1]: elasticsearch.service: Unit entered failed state.
nov. 26 11:50:41 debian systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

```

Le problème semble donc provenir de JAVA\_HOME.  
Cependant en faisant un "echo $JAVA\_HOME" j'ai le retour suivant :

```auto
root@debian:~# echo $JAVA_HOME
/usr/lib/jvm/java-1.8.0-openjdk-i386

```

Voici a quoi ressemble mon /etc/profile :

```auto
# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if ["`id -u`" -eq 0]; then
  PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
else
  PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
fi
export PATH

if ["${PS1-}"]; then
  if ["${BASH-}"] && ["$BASH" != "/bin/sh"]; then
    # The file bash.bashrc already sets the default PS1.
    # PS1='\h:\w\$ '
    if [-f /etc/bash.bashrc]; then
      . /etc/bash.bashrc
    fi
  else
    if ["`id -u`" -eq 0]; then
      PS1='# '
    else
      PS1='$ '
    fi
  fi
fi

if [-d /etc/profile.d]; then
  for i in /etc/profile.d/*.sh; do
    if [-r $i]; then
      . $i
    fi
  done
  unset i
fi

export JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk-i386
export PATH=${JAVA_HOME}/bin:${PATH}
export JRE_HOME
export PATH

```

Est-ce qu'il y a une coquille ? Besoin d'informations supplémentaires ?  
Je commence a desespérer. 😕

Merci d'avance !

---

<div class="post-metadata">

**Author:** ![gabriel\_tessier](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_tessier/32/27911_2.png) [@gabriel\_tessier](https://discuss.elastic.co/u/gabriel_tessier)\
**Post date:** [November 27, 2019, 2:42am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483/2 "2019-11-27T02:42:21Z")

</div>

Bonjour @Theo_Meteyer,

As-tu installé a partir d'un .deb?  
quelle version?  
quel tutoriel d'installation as-tu suivi?

---

<div class="post-metadata">

**Author:** ![Theo\_Meteyer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theo_meteyer/32/58352_2.png) [@Theo\_Meteyer](https://discuss.elastic.co/u/Theo_Meteyer)\
**Post date:** [November 27, 2019, 7:28am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483/3 "2019-11-27T07:28:30Z")

</div>

Bonjour @gabriel_tessier,

tout d'abord, merci d'intervenir 🙂 !  
J'ai installé depuis un paquet en ligne en suivant ces tuto (peut-être d'autres également mais en grande partie ceux la) :

[https://docs.graylog.org/en/3.1/pages/installation/os/debian.html](https://docs.graylog.org/en/3.1/pages/installation/os/debian.html)  
[https://www.webitcs.net/systemes/linux/debian/installer-et-configurer-graylog3.0-sous-debian9.php](https://www.webitcs.net/systemes/linux/debian/installer-et-configurer-graylog3.0-sous-debian9.php)

Elasticsearch en version 6.8.

* * *

En allant dans "/etc/default/elasticsearch" et en rajoutant la ligne suivante, il s'avère que le problème est résolu..

> JAVA\_HOME=/usr/lib/jvm/java-1.8.0-openjdk-i386

Cependant un autre apparait. Ca serait pas drôle sinon 🙄

> root@debian:~# service elasticsearch status  
> â elasticsearch.service - Elasticsearch  
> Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
> Active: failed (Result: exit-code) since Tue 2019-11-26 14:40:31 CET; 14s ago  
> Docs: [http://www.elastic.co](http://www.elastic.co)  
> Process: 1923 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=ex  
> Main PID: 1923 (code=exited, status=1/FAILURE)  
> nov. 26 14:39:50 debian systemd[1]: Started Elasticsearch.  
> nov. 26 14:40:31 debian systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
> nov. 26 14:40:31 debian systemd[1]: elasticsearch.service: Unit entered failed state.  
> nov. 26 14:40:31 debian systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

Et la, je ne vois vraiment pas ce qui peut être fait..  
Une idée ?

---

<div class="post-metadata">

**Author:** ![gabriel\_tessier](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_tessier/32/27911_2.png) [@gabriel\_tessier](https://discuss.elastic.co/u/gabriel_tessier)\
**Post date:** [November 29, 2019, 4:03am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483/4 "2019-11-29T04:03:13Z")

</div>

@Theo_Meteyer

Tu devrais avoir plus de détails dans les fichiers de logs.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 27, 2019, 4:15am UTC](https://discuss.elastic.co/t/debian-probleme-lancement-elasticsearch/209483/5 "2019-12-27T04:15:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
