# Default configuration Local installation of ES on windows 10

**URL:** <https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [June 28, 2022, 12:42pm UTC](https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356 "2022-06-28T12:42:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ftayyab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ftayyab/32/107635_2.png) [@ftayyab](https://discuss.elastic.co/u/ftayyab)\
**Post date:** [June 28, 2022, 12:42pm UTC](https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356/1 "2022-06-28T12:42:58Z")

</div>

Hello,

I am able to run ES and Kibana on window 10 machine with default configuration. However if I shut down the ES process and try to start ES again after few days, I get the following:

```auto
java.security.cert.CertificateException: No subject alternative names matching IP address x.x.x.x found

ERROR: Failed to determine the health of the cluster.

```

I can still browse to Elasticsearch and get a response but I am unable to establish a connection from kibana.

From the console (for kibana), I can see:

`Unable to retrieve version information from Elasticsearch nodes. Client network socket disconnected before secure TLS connection was established - Local: unknown:unknown, Remote: unknown:unknown`

i also cannot run any of the other batch commands for example for enrolling a token or node. It just throws the certificateexception and same error.

Any ideas why this is the case.

I have no problems when I first download ES and run it for the first time. Everything works including kibana but after a day or so restarting ES get the certificate exception.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 28, 2022, 11:36pm UTC](https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356/2 "2022-06-28T23:36:56Z")

</div>

> [@ftayyab](#):
>
> ```auto
> java.security.cert.CertificateException: No subject alternative names matching IP address x.x.x.x found
> 
> ```

That suggests that the networking IP and /or hostname of your machine is changing, is that correct?

---

<div class="post-metadata">

**Author:** ![ftayyab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ftayyab/32/107635_2.png) [@ftayyab](https://discuss.elastic.co/u/ftayyab)\
**Post date:** [June 29, 2022, 8:59am UTC](https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356/3 "2022-06-29T08:59:05Z")

</div>

Hi Mark,

Correct. On restart of the machine, new IP address is assigned and as the IP address changes, the kibana \<-\> ES connection stops working. As a solution, I updated the kibana.yml file by removing the autoconfigured ipaddress and added localhost in the elasticsearch.hosts option. Things started to work again.

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 27, 2022, 8:59am UTC](https://discuss.elastic.co/t/default-configuration-local-installation-of-es-on-windows-10/308356/4 "2022-07-27T08:59:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
