# Delete Mapping Not Working

**URL:** <https://discuss.elastic.co/t/delete-mapping-not-working/12414>\
**Category:** Elasticsearch\
**Created:** [June 14, 2013, 8:32am UTC](https://discuss.elastic.co/t/delete-mapping-not-working/12414 "2013-06-14T08:32:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tarang\_dawer](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@tarang\_dawer](https://discuss.elastic.co/u/tarang_dawer)\
**Post date:** [June 14, 2013, 8:32am UTC](https://discuss.elastic.co/t/delete-mapping-not-working/12414/1 "2013-06-14T08:32:59Z")

</div>

Hi  
I am using ES-0.90.0.RC2

I created an index "test" in ES , with 5 shards and 1 replica.  
I am trying to delete a mapping in ES .  
When i issue the delete command

[http://192.168.145.144:9200/test/content/\_mapping](http://192.168.145.144:9200/test/content/_mapping) through REST Client,  
with method as DELETE , it returns the status

{"ok":true}

After checking through the stats/status api, it reflects logically deleted  
documents, but no reduction in size .Size remains same on the physical disk  
as well.

So i tried optimizing the index, with command

[http://192.168.145.144:9200/test/\_optimize?only\_expunge\_deletes=true](http://192.168.145.144:9200/test/_optimize?only_expunge_deletes=true)  
through the REST Client, with method as get , and it returns status

{"ok":true,"\_shards":{"total":10,"successful":10,"failed":0}}

But, on the ES console , it shows Some exception for each primary shard.

Still , on checking the status/stats API , size is still the same (before  
deletion) and on physical disk as well.

Please help me out , as am not able to figure out exactly where am i going  
wrong.

Thanks in Advance  
Tarang Dawer

[2013-06-14 13:48:44,457][WARN][index.engine.robin] [Dreamqueen]  
[test][4] failed engine  
org.apache.lucene.index.MergePolicy$MergeException:  
org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
for field: [content]  
at  
org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:100)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
mapper found for field: [content]  
at  
org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
at  
org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
at  
org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
at  
org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
at  
org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
at  
org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
at  
org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
at  
org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)  
[2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
sending failed shard for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
s[STARTED], reason [engine failure, message  
[MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
index mapper found for field: [content]]; nested:  
ElasticSearchIllegalStateException[no index mapper found for field:  
[content]]; ]]  
[2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
received shard failed for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
s[STARTED], reason [engine failure, message  
[MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
index mapper found for field: [content]]; nested:  
ElasticSearchIllegalStateException[no index mapper found for field:  
[content]]; ]]  
Exception in thread "elasticsearch[Dreamqueen][[test][4]: Lucene Merge  
Thread #0]" org.apache.lucene.index.MergePolicy$MergeException:  
org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
for field: [content]  
at  
org.apache.lucene.index.ConcurrentMergeScheduler.handleMergeException(ConcurrentMergeScheduler.java:541)  
at  
org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:101)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
mapper found for field: [content]  
at  
org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
at  
org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
at  
org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
at  
org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
at  
org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
at  
org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
at  
org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
at  
org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
at  
org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![tarang\_dawer](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@tarang\_dawer](https://discuss.elastic.co/u/tarang_dawer)\
**Post date:** [June 14, 2013, 9:36am UTC](https://discuss.elastic.co/t/delete-mapping-not-working/12414/2 "2013-06-14T09:36:56Z")

</div>

Hi  
Seems like it was some sort of a bug in 0.90.0RC2 , found a workaround ,  
after deletion call, a create mapping call , and then issue optimize .

otherwise , in 0.90.1 , it works fine.

On Fri, Jun 14, 2013 at 2:02 PM, Tarang Dawer [tarang.dawer@gmail.com](mailto:tarang.dawer@gmail.com)wrote:

> Hi  
> I am using ES-0.90.0.RC2
> 
> I created an index "test" in ES , with 5 shards and 1 replica.  
> I am trying to delete a mapping in ES .  
> When i issue the delete command
> 
> [http://192.168.145.144:9200/test/content/\_mapping](http://192.168.145.144:9200/test/content/_mapping) through REST Client,  
> with method as DELETE , it returns the status
> 
> {"ok":true}
> 
> After checking through the stats/status api, it reflects logically deleted  
> documents, but no reduction in size .Size remains same on the physical disk  
> as well.
> 
> So i tried optimizing the index, with command
> 
> [http://192.168.145.144:9200/test/\_optimize?only\_expunge\_deletes=true](http://192.168.145.144:9200/test/_optimize?only_expunge_deletes=true)  
> through the REST Client, with method as get , and it returns status
> 
> {"ok":true,"\_shards":{"total":10,"successful":10,"failed":0}}
> 
> But, on the ES console , it shows Some exception for each primary shard.
> 
> Still , on checking the status/stats API , size is still the same (before  
> deletion) and on physical disk as well.
> 
> Please help me out , as am not able to figure out exactly where am i going  
> wrong.
> 
> Thanks in Advance  
> Tarang Dawer
> 
> [2013-06-14 13:48:44,457][WARN][index.engine.robin] [Dreamqueen]  
> [test][4] failed engine  
> org.apache.lucene.index.MergePolicy$MergeException:  
> org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
> for field: [content]  
> at  
> org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:100)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
> Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
> mapper found for field: [content]  
> at  
> org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
> at  
> org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
> at  
> org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
> at  
> org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
> at  
> org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
> at  
> org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
> at  
> org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
> at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
> at  
> org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)  
> [2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
> sending failed shard for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
> s[STARTED], reason [engine failure, message  
> [MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
> index mapper found for field: [content]]; nested:  
> ElasticSearchIllegalStateException[no index mapper found for field:  
> [content]]; ]]  
> [2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
> received shard failed for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
> s[STARTED], reason [engine failure, message  
> [MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
> index mapper found for field: [content]]; nested:  
> ElasticSearchIllegalStateException[no index mapper found for field:  
> [content]]; ]]  
> Exception in thread "elasticsearch[Dreamqueen][[test][4]: Lucene Merge  
> Thread #0]" org.apache.lucene.index.MergePolicy$MergeException:  
> org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
> for field: [content]  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler.handleMergeException(ConcurrentMergeScheduler.java:541)  
> at  
> org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:101)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
> Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
> mapper found for field: [content]  
> at  
> org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
> at  
> org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
> at  
> org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
> at  
> org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
> at  
> org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
> at  
> org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
> at  
> org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
> at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
> at  
> org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
> at  
> org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![mvg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mvg/32/98890_2.png) [@mvg](https://discuss.elastic.co/u/mvg)\
**Post date:** [June 14, 2013, 11:48am UTC](https://discuss.elastic.co/t/delete-mapping-not-working/12414/3 "2013-06-14T11:48:18Z")

</div>

Hi,

This has been fixed via:

> <https://github.com/elastic/elasticsearch/issues/3088>
>
> Today I've been getting horrible performance on 0.90 server I upgraded last week…. Running on Ubuntu, Ruby 1.9.3, Rails 3.2.3, with the Stretcher gem.
> 
> The issue is in bulk indexing Twitter data, with JSON very similar to the response shown at: https://dev.twitter.com/docs/api/1.1/get/statuses/user\_timeline, except the user node of each item is removed and is instead a parent document (although I don't think that is the issue).
> 
> My mappings are intentionally kept simple, using dynamic mappings to add fields. Everything has been working fine to this point. Now I'm getting the following error, bringing the server to its knees.
> 
> The error is:
> \[2013-05-23 22:13:01,792\]\[WARN \]\[index.merge.scheduler \] \[Rocket Racer\] \[twitter\_history\_76816072\]\[1\] failed to merge
> org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found for field: \[entities.description.urls.display\_url\]
> at org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)
> at org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)
> at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)
> at org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)
> at org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)
> at org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)
> at org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)
> at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)
> at org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)
> at org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)
> at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)
> \[2013-05-23 22:13:01,939\]\[WARN \]\[index.engine.robin \] \[Rocket Racer\] \[twitter\_history\_76816072\]\[1\] failed engine
> org.apache.lucene.index.MergePolicy$MergeException: org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found for field: \[entities.description.urls.display\_url\]
> at org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:100)
> at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)
> Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found for field: \[entities.description.urls.display\_url\]
> at org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)
> at org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)
> at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)
> at org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)
> at org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)
> at org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)
> at org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)
> at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)
> at org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)
> at org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)
> at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)
> \[2013-05-23 22:13:04,187\]\[WARN \]\[cluster.action.shard \] \[Rocket Racer\] sending failed shard for \[twitter\_history\_76816072\]\[1\], node\[\_1cPivHASUOzVcgQ2fK0\_A\], \[P\], s\[INITIALIZING\], reason \[engine failure, message \[MergeException\[org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found for field: \[entities.description.urls.display\_url\]\]; nested: ElasticSearchIllegalStateException\[no index mapper found for field: \[entities.description.urls.display\_url\]\]; \]\]
> \[2013-05-23 22:13:04,234\]\[WARN \]\[cluster.action.shard \] \[Rocket Racer\] received shard failed for \[twitter\_history\_76816072\]\[1\], node\[\_1cPivHASUOzVcgQ2fK0\_A\], \[P\], s\[INITIALIZING\], reason \[engine failure, message \[MergeException\[org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found for field: \[entities.description.urls.display\_url\]\]; nested: ElasticSearchIllegalStateException\[no index mapper found for field: \[entities.description.urls.display\_url\]\]; \]\]
> \[2013-05-23 22:13:07,433\]\[WARN \]\[indices.cluster \] \[Rocket Racer\] \[twitter\_history\_76816072\]\[1\] master \[\[Rocket Racer\]\[\_1cPivHASUOzVcgQ2fK0\_A\]\[inet\[/10.178.13.201:9300\]\]\] marked shard as started, but shard have not been created, mark shard as failed
> \[2013-05-23 22:13:07,446\]\[WARN \]\[cluster.action.shard \] \[Rocket Racer\] sending failed shard for \[twitter\_history\_76816072\]\[1\], node\[\_1cPivHASUOzVcgQ2fK0\_A\], \[P\], s\[STARTED\], reason \[master \[Rocket Racer\]\[\_1cPivHASUOzVcgQ2fK0\_A\]\[inet\[/10.178.13.201:9300\]\] marked shard as started, but shard have not been created, mark shard as failed\]
> \[2013-05-23 22:13:07,446\]\[WARN \]\[cluster.action.shard \] \[Rocket Racer\] received shard failed for \[twitter\_history\_76816072\]\[1\], node\[\_1cPivHASUOzVcgQ2fK0\_A\], \[P\], s\[STARTED\], reason \[master \[Rocket Racer\]\[\_1cPivHASUOzVcgQ2fK0\_A\]\[inet\[/10.178.13.201:9300\]\] marked shard as started, but shard have not been created, mark shard as failed\]
> 
> The best guess I have is that some random data is breaking the creation of new mappings. The same is happening on the same index in both production and test environments. Other indexes with the same initial mappings but different Twitter data content are not exhibiting the same error. 
> 
> I'm trying to capture the data, although there is a mass of it. Therefore before I go too far, has anybody got any clue how I can start to identify the source of the problem?

The fix is included in version 0.90.1

Martijn

On 14 June 2013 11:36, Tarang Dawer [tarang.dawer@gmail.com](mailto:tarang.dawer@gmail.com) wrote:

> Hi  
> Seems like it was some sort of a bug in 0.90.0RC2 , found a workaround ,  
> after deletion call, a create mapping call , and then issue optimize .
> 
> otherwise , in 0.90.1 , it works fine.
> 
> On Fri, Jun 14, 2013 at 2:02 PM, Tarang Dawer [tarang.dawer@gmail.com](mailto:tarang.dawer@gmail.com)wrote:
> 
> > Hi  
> > I am using ES-0.90.0.RC2
> > 
> > I created an index "test" in ES , with 5 shards and 1 replica.  
> > I am trying to delete a mapping in ES .  
> > When i issue the delete command
> > 
> > [http://192.168.145.144:9200/test/content/\_mapping](http://192.168.145.144:9200/test/content/_mapping) through REST Client,  
> > with method as DELETE , it returns the status
> > 
> > {"ok":true}
> > 
> > After checking through the stats/status api, it reflects logically  
> > deleted documents, but no reduction in size .Size remains same on the  
> > physical disk as well.
> > 
> > So i tried optimizing the index, with command
> > 
> > [http://192.168.145.144:9200/test/\_optimize?only\_expunge\_deletes=true](http://192.168.145.144:9200/test/_optimize?only_expunge_deletes=true)  
> > through the REST Client, with method as get , and it returns status
> > 
> > {"ok":true,"\_shards":{"total":10,"successful":10,"failed":0}}
> > 
> > But, on the ES console , it shows Some exception for each primary shard.
> > 
> > Still , on checking the status/stats API , size is still the same (before  
> > deletion) and on physical disk as well.
> > 
> > Please help me out , as am not able to figure out exactly where am i  
> > going wrong.
> > 
> > Thanks in Advance  
> > Tarang Dawer
> > 
> > [2013-06-14 13:48:44,457][WARN][index.engine.robin] [Dreamqueen]  
> > [test][4] failed engine  
> > org.apache.lucene.index.MergePolicy$MergeException:  
> > org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
> > for field: [content]  
> > at  
> > org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:100)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
> > Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
> > mapper found for field: [content]  
> > at  
> > org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
> > at  
> > org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
> > at  
> > org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
> > at  
> > org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
> > at  
> > org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
> > at  
> > org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
> > at  
> > org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
> > at  
> > org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
> > at  
> > org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)  
> > [2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
> > sending failed shard for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
> > s[STARTED], reason [engine failure, message  
> > [MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
> > index mapper found for field: [content]]; nested:  
> > ElasticSearchIllegalStateException[no index mapper found for field:  
> > [content]]; ]]  
> > [2013-06-14 13:48:44,522][WARN][cluster.action.shard] [Dreamqueen]  
> > received shard failed for [test][4], node[p4Ik84RrSGqJ6pPcknvyUw], [P],  
> > s[STARTED], reason [engine failure, message  
> > [MergeException[org.elasticsearch.ElasticSearchIllegalStateException: no  
> > index mapper found for field: [content]]; nested:  
> > ElasticSearchIllegalStateException[no index mapper found for field:  
> > [content]]; ]]  
> > Exception in thread "elasticsearch[Dreamqueen][[test][4]: Lucene Merge  
> > Thread #0]" org.apache.lucene.index.MergePolicy$MergeException:  
> > org.elasticsearch.ElasticSearchIllegalStateException: no index mapper found  
> > for field: [content]  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler.handleMergeException(ConcurrentMergeScheduler.java:541)  
> > at  
> > org.elasticsearch.index.merge.scheduler.ConcurrentMergeSchedulerProvider$CustomConcurrentMergeScheduler.handleMergeException(ConcurrentMergeSchedulerProvider.java:101)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:514)  
> > Caused by: org.elasticsearch.ElasticSearchIllegalStateException: no index  
> > mapper found for field: [content]  
> > at  
> > org.elasticsearch.index.codec.PerFieldMappingPostingFormatCodec.getPostingsFormatForField(PerFieldMappingPostingFormatCodec.java:52)  
> > at  
> > org.apache.lucene.codecs.lucene42.Lucene42Codec$1.getPostingsFormatForField(Lucene42Codec.java:59)  
> > at  
> > org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsWriter.addField(PerFieldPostingsFormat.java:102)  
> > at  
> > org.apache.lucene.codecs.FieldsConsumer.merge(FieldsConsumer.java:71)  
> > at  
> > org.apache.lucene.index.SegmentMerger.mergeTerms(SegmentMerger.java:383)  
> > at  
> > org.apache.lucene.index.SegmentMerger.merge(SegmentMerger.java:116)  
> > at  
> > org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:3693)  
> > at  
> > org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:3296)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:401)  
> > at  
> > org.apache.lucene.index.TrackingConcurrentMergeScheduler.doMerge(TrackingConcurrentMergeScheduler.java:91)  
> > at  
> > org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:478)
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
Met vriendelijke groet,

Martijn van Groningen

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:31am UTC](https://discuss.elastic.co/t/delete-mapping-not-working/12414/4 "2017-07-06T02:31:16Z")

</div>


