# Dependecias logstash

**URL:** <https://discuss.elastic.co/t/dependecias-logstash/111139>\
**Category:** Elastic en Español\
**Created:** [December 11, 2017, 4:22pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139 "2017-12-11T16:22:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Erick\_Garcia\_Perez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erick_garcia_perez/32/22244_2.png) [@Erick\_Garcia\_Perez](https://discuss.elastic.co/u/Erick_Garcia_Perez)\
**Post date:** [December 11, 2017, 4:22pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139/1 "2017-12-11T16:22:41Z")

</div>

hola buenos dias, epsero me ayuden!  
Cuando intento arrancar logstash me sale lo siguiente:

[clusterelastic@linux-z38e:~/cluster1/Nodo1/logapacheerror/logstash-5.5.2/bin] sh logstash -f configuracion.conf

LoadError: no such file to load -- bundler/gem\_path\_manipulation

require at org/jruby/RubyKernel.java:1040

require at /home/clusterelastic/cluster1/Nodo1/logapacheerror/logstash-5.5.2/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:54

(root) at /home/clusterelastic/cluster1/Nodo1/logapacheerror/logstash-5.5.2/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:4

require at org/jruby/RubyKernel.java:1040

(root) at /home/clusterelastic/cluster1/Nodo1/logapacheerror/logstash-5.5.2/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:1

require at /home/clusterelastic/cluster1/Nodo1/logapacheerror/logstash-5.5.2/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:128

(root) at /home/clusterelastic/cluster1/Nodo1/logapacheerror/logstash-5.5.2/lib/bootstrap/environment.rb:67

---

<div class="post-metadata">

**Author:** ![gmoskovicz](https://avatars.discourse-cdn.com/v4/letter/g/ecae2f/32.png) [@gmoskovicz](https://discuss.elastic.co/u/gmoskovicz)\
**Post date:** [December 11, 2017, 5:30pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139/2 "2017-12-11T17:30:31Z")

</div>

Hola!

Creo que esto parece un problema con tu servidor. Puedes ver un problema similar aqui: [https://github.com/elastic/logstash/issues/6052](https://github.com/elastic/logstash/issues/6052).

No necesitas hacer `sh` no se si eso lo esta causando, pero no es un problema con logstash sino mas con el sistema en el que lo estas corriendo.

Saludos!  
--Gabriel

---

<div class="post-metadata">

**Author:** ![Erick\_Garcia\_Perez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erick_garcia_perez/32/22244_2.png) [@Erick\_Garcia\_Perez](https://discuss.elastic.co/u/Erick_Garcia_Perez)\
**Post date:** [December 11, 2017, 7:42pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139/3 "2017-12-11T19:42:59Z")

</div>

buenas tardes, lo que pasa es que yo no lo instale, lo corro en open suse y ejecuto logstash con sh pero me da error, creo que faltan unas dependencias o algo asi, pero no se cuales

---

<div class="post-metadata">

**Author:** ![gmoskovicz](https://avatars.discourse-cdn.com/v4/letter/g/ecae2f/32.png) [@gmoskovicz](https://discuss.elastic.co/u/gmoskovicz)\
**Post date:** [December 19, 2017, 7:37pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139/4 "2017-12-19T19:37:07Z")

</div>

Hola Erick,

Como te digo, esto es un problema de la instalación, o de el sistema operativo que tu tienes. Los problemas con `Bundler` generalmente son de allí. Te recomiendo que chequeen la instalación.

Saludos!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 16, 2018, 7:37pm UTC](https://discuss.elastic.co/t/dependecias-logstash/111139/5 "2018-01-16T19:37:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
