# Deprecated field \[inline\] used, expected \[source\] instead & Deprecated field \[all\_fields\] used, replaced by \[Set \[fields\] to \`\*\` instead\]

**URL:** <https://discuss.elastic.co/t/deprecated-field-inline-used-expected-source-instead-deprecated-field-all-fields-used-replaced-by-set-fields-to-instead/164396>\
**Category:** Elasticsearch\
**Created:** [January 16, 2019, 1:19am UTC](https://discuss.elastic.co/t/deprecated-field-inline-used-expected-source-instead-deprecated-field-all-fields-used-replaced-by-set-fields-to-instead/164396 "2019-01-16T01:19:11Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sjaak01](https://avatars.discourse-cdn.com/v4/letter/s/73ab20/32.png) [@Sjaak01](https://discuss.elastic.co/u/Sjaak01)\
**Post date:** [January 16, 2019, 1:19am UTC](https://discuss.elastic.co/t/deprecated-field-inline-used-expected-source-instead-deprecated-field-all-fields-used-replaced-by-set-fields-to-instead/164396/1 "2019-01-16T01:19:11Z")

</div>

Hi,

Elasticsearch 6.5.4

I was going over the Elastic cloud logs today and found these two warnings reoccurring. I did some googling but couldn't find a root case.

`Deprecated field [inline] used, expected [source] instead`  
`Deprecated field [all_fields] used, replaced by [Set [fields] to`\*`instead]`

The later appears to be caused by scripted fields? The only scripted field I have is `doc['in_bytes'].value + doc['out_bytes'].value`. Is there anything wrong with the script on 6.x? I don't believe I had any issues with it on 5.x.

PS. These errors don't show up in Kibana and data appears to be loading fine. I started looking into it because one dashboard occasionally gives the error below. When reloading the page the error doesn't appear.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/8/78640d855f8ddb59a3c1242e4f7c3d86323f4d3f.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 13, 2019, 1:19am UTC](https://discuss.elastic.co/t/deprecated-field-inline-used-expected-source-instead-deprecated-field-all-fields-used-replaced-by-set-fields-to-instead/164396/2 "2019-02-13T01:19:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
