# Did any body try using hadoop-fuse mounted file system instead of local file system?

**URL:** https://discuss.elastic.co/t/did-any-body-try-using-hadoop-fuse-mounted-file-system-instead-of-local-file-system/7405
**Category:** Elasticsearch
**Created:** [April 19, 2012, 9:51pm UTC](https://discuss.elastic.co/t/did-any-body-try-using-hadoop-fuse-mounted-file-system-instead-of-local-file-system/7405 "2012-04-19T21:51:49Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Anita](https://avatars.discourse-cdn.com/v4/letter/a/49beb7/32.png) [@Anita](https://discuss.elastic.co/u/Anita)
#### Post date: [April 19, 2012, 9:51pm UTC](https://discuss.elastic.co/t/did-any-body-try-using-hadoop-fuse-mounted-file-system-instead-of-local-file-system/7405/1 "2012-04-19T21:51:49Z")

</div>

Hi all,

Did anyone try using hadoop-fuse mounted file system to store ElasticSearch index/meta data? Does ElasticSearch support this?

I am getting these errors.

org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [order][0] failed recovery  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:228)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:619)  
Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [order][0] Failed to open reader on writer  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:281)  
at org.elasticsearch.index.shard.service.InternalIndexShard.start(InternalIndexShard.java:272)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:132)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)  
... 3 more  
Caused by: java.io.IOException: Operation not supported  
at java.io.RandomAccessFile.writeBytes(Native Method)  
at java.io.RandomAccessFile.write(RandomAccessFile.java:466)  
at org.apache.lucene.store.FSDirectory$FSIndexOutput.flushBuffer(FSDirectory.java:448)

What are the guidelines to scale large data in terms of disk space and memory? How does hadoop gateway help?

Thanks in advance for all your inputs.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:31am UTC](https://discuss.elastic.co/t/did-any-body-try-using-hadoop-fuse-mounted-file-system-instead-of-local-file-system/7405/2 "2017-07-06T03:31:49Z")

</div>


