# Disable "amazon\_es" output plugin console logs

**URL:** https://discuss.elastic.co/t/disable-amazon-es-output-plugin-console-logs/209995
**Category:** Logstash
**Created:** [November 29, 2019, 6:24pm UTC](https://discuss.elastic.co/t/disable-amazon-es-output-plugin-console-logs/209995 "2019-11-29T18:24:43Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ArunANayagam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arunanayagam/32/45171_2.png) [@ArunANayagam](https://discuss.elastic.co/u/ArunANayagam)
#### Post date: [November 29, 2019, 6:24pm UTC](https://discuss.elastic.co/t/disable-amazon-es-output-plugin-console-logs/209995/1 "2019-11-29T18:24:43Z")

</div>

Hi,

I use a docker logstash (7.1.1) and write to AWS ES via amazon\_es output plugin.

The plugin as such works fine, but then all the messages are printed on the console and that generates a lot of I/O on disk, making the box unresponsive.

I have tried ,  
1.setting logstash.yml log.level: error, doesn't help  
2. Overwrote log4j2.properties with this content, doesn't help either

```
status = error
name = PropertiesConfig
    filters = threshold

filter.threshold.type = ThresholdFilter
filter.threshold.level = debug

appenders = console

appender.console.type = Console
appender.console.name = STDOUT
appender.console.layout.type = PatternLayout
appender.console.layout.pattern = %d{yyyy-MM-dd HH:mm:ss} %-5p %c{1}:%L - %m%n

rootLogger.level = error
rootLogger.appenderRefs = stdout
rootLogger.appenderRef.stdout.ref = STDOUT

```

Are there other ways to switch off console logs?

Appreciate your help on this.

Thanks,  
Arun

---

<div class="post-metadata">

### Author: ![ArunANayagam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arunanayagam/32/45171_2.png) [@ArunANayagam](https://discuss.elastic.co/u/ArunANayagam)
#### Post date: [December 27, 2019, 9:21am UTC](https://discuss.elastic.co/t/disable-amazon-es-output-plugin-console-logs/209995/2 "2019-12-27T09:21:01Z")

</div>

Hi,  
It turned out to be the default, /usr/share/logstash/pipeline/logstash.conf that was writing to the console. Since it's a Docker installation I overwrote the file in the "volumes" section.

And that has resolved the issue.

Thanks,  
Arun

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 24, 2020, 9:21am UTC](https://discuss.elastic.co/t/disable-amazon-es-output-plugin-console-logs/209995/3 "2020-01-24T09:21:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
