# Disable APM Remote configuration Errors

**URL:** <https://discuss.elastic.co/t/disable-apm-remote-configuration-errors/249744>\
**Category:** APM\
**Tags:** server\
**Created:** [September 24, 2020, 6:40am UTC](https://discuss.elastic.co/t/disable-apm-remote-configuration-errors/249744 "2020-09-24T06:40:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Loran\_Fininure](https://avatars.discourse-cdn.com/v4/letter/l/4da419/32.png) [@Loran\_Fininure](https://discuss.elastic.co/u/Loran_Fininure)\
**Post date:** [September 24, 2020, 6:41am UTC](https://discuss.elastic.co/t/disable-apm-remote-configuration-errors/249744/1 "2020-09-24T06:41:00Z")

</div>

**Kibana version** : 7.8.1

**Elasticsearch version** : 7.8.1

**APM Server version** : 7.8.1

**Is there anything special in your setup?**  
rum:  
enabled: false  
ilm:  
setup:  
enabled: false  
overwrite: false  
We use the template that is generated by _apm-server export template_

**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**:  
We get about 36k error messages per day that say: "forbidden request: Agent remote configuration is disabled. Configure the `apm-server.kibana` section in apm-server.yml to enable it. If you are using a RUM agent, you also need to configure the `apm-server.rum` section. If you are not using remote configuration, you can safely ignore this error."

I know that I can ignore those, but its cluttering the log and disk.  
Is there any way to suppress this message or to tell the APM-Agent not to try accessing remot configuration?

---

<div class="post-metadata">

**Author:** ![Hamidreza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hamidreza/32/21369_2.png) [@Hamidreza](https://discuss.elastic.co/u/Hamidreza)\
**Post date:** [September 24, 2020, 11:58am UTC](https://discuss.elastic.co/t/disable-apm-remote-configuration-errors/249744/2 "2020-09-24T11:58:27Z")

</div>

Hi @Loran_Fininure,

Thanks for reaching out.

The central config is disabled by default in the RUM agent, you can see the configuration [here](https://www.elastic.co/guide/en/apm/agent/rum-js/current/configuration.html#central-config).

However, that message can be logged if one of the backend agents requests the configuration. Backend agents have central config enabled by default but there's a configuration to disable it. Please see [this guide to find the right configuration for each agent](https://www.elastic.co/guide/en/kibana/7.9/agent-configuration.html).

Hope this helps,  
Hamid

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 15, 2020, 7:58am UTC](https://discuss.elastic.co/t/disable-apm-remote-configuration-errors/249744/3 "2020-10-15T07:58:34Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
