# Discover can not show all the doc

**URL:** <https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135>\
**Category:** Kibana\
**Created:** [August 6, 2018, 9:47am UTC](https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135 "2018-08-06T09:47:50Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![cythwell](https://avatars.discourse-cdn.com/v4/letter/c/f475e1/32.png) [@cythwell](https://discuss.elastic.co/u/cythwell)\
**Post date:** [August 6, 2018, 9:47am UTC](https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135/1 "2018-08-06T09:47:50Z")

</div>

I have two indices: onwards-access-**, onwards-error-\*\*_.  
There are 6 docs inside onwards-access-_, and 2 docs inside onwards-error-**  
But there are just onwards-access-\*\*\*\* shown in Discover.

get onwards-error-2018.08.06/doc/\_search  
{  
"took": 0,  
"timed\_out": false,  
"\_shards": {  
"total": 3,  
"successful": 3,  
"skipped": 0,  
"failed": 0  
},  
"hits": {  
"total": 2,  
"max\_score": 1,

![image](https://us1.discourse-cdn.com/elastic/original/3X/9/6/96bc9b3d3f4d2e8b1cb96a10c1301ff98d6502eb.png)

Best wish

---

<div class="post-metadata">

**Author:** ![christophilus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christophilus/32/42991_2.png) [@christophilus](https://discuss.elastic.co/u/christophilus)\
**Post date:** [August 6, 2018, 2:44pm UTC](https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135/2 "2018-08-06T14:44:13Z")

</div>

Hm. It's not clear which Kibana version you're using, but here are a few things to check:

Is your time range excluding documents? Try setting your time range to something big and see if this changes.

The second thing you might try doing, is bumping up your refresh rate from 15 minutes (the default) to something higher to see if you're just looking at stale data.

Best,  
C

---

<div class="post-metadata">

**Author:** ![cythwell](https://avatars.discourse-cdn.com/v4/letter/c/f475e1/32.png) [@cythwell](https://discuss.elastic.co/u/cythwell)\
**Post date:** [August 7, 2018, 2:26am UTC](https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135/5 "2018-08-07T02:26:24Z")

</div>

Hi @christophilus, I can see error log not. The issue is the @timestamp not correct.  
the access log got timestamp field as 2018-08-06T09:22:24.000Z , which is correct , while the error log got 2018-08-06T17:22:24.000Z.  
that lead to the error can not shown in log of 2018-08-06...  
So the root cause should be the filebeat , whom sent the log to elasticsearch,  
thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 4, 2018, 2:26am UTC](https://discuss.elastic.co/t/discover-can-not-show-all-the-doc/143135/6 "2018-09-04T02:26:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
