# Distress: Elasticsearch 6.4.0 fails to start

**URL:** <https://discuss.elastic.co/t/distress-elasticsearch-6-4-0-fails-to-start/152296>\
**Category:** Elasticsearch\
**Created:** [October 12, 2018, 7:54pm UTC](https://discuss.elastic.co/t/distress-elasticsearch-6-4-0-fails-to-start/152296 "2018-10-12T19:54:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rsmoorthy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rsmoorthy/32/35975_2.png) [@rsmoorthy](https://discuss.elastic.co/u/rsmoorthy)\
**Post date:** [October 12, 2018, 7:54pm UTC](https://discuss.elastic.co/t/distress-elasticsearch-6-4-0-fails-to-start/152296/1 "2018-10-12T19:54:23Z")

</div>

Elasticsearch 6.4.0 fails to start with Java IO exception:

> org.elasticsearch.ElasticsearchException: java.io.IOException: failed to read [id:305, file:/var/lib/elasticsearch/nodes/0/\_state/global-305.st]

Please see [Distress: Elasticsearch does not start - #3 by dakrone](https://discuss.elastic.co/t/distress-elasticsearch-does-not-start/152288/3) for more details, but here is the quick summary:

1. ELK 541 working fine.
2. Upgraded to ELK640, ES640 and Kibana640 came up fine, Logstash 640 had some issues.
3. Went back to ELK 541 (possibly this was the mistake! ☹ It did not come up. As possibly downgrading is not supported.
4. Came back to ELK 640 - but it wont start now. Possibly corrupted data?

Full error log at [ES640 Fails to start · GitHub](https://gist.github.com/rsmoorthy/132223e7540edc2c73c2827f8ebb732d)

Any help to recover the data is appreciated!!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 12, 2018, 8:24pm UTC](https://discuss.elastic.co/t/distress-elasticsearch-6-4-0-fails-to-start/152296/2 "2018-10-12T20:24:30Z")

</div>

Please don't post the same thing more than once, it makes it harder for people to help 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 12, 2018, 8:24pm UTC](https://discuss.elastic.co/t/distress-elasticsearch-6-4-0-fails-to-start/152296/3 "2018-10-12T20:24:33Z")

</div>


