# DNS lookup failure "my-cluster-es-http": lookup my-cluster-es-http on 1xx.xx.xx.xx:53: no such host

**URL:** https://discuss.elastic.co/t/dns-lookup-failure-my-cluster-es-http-lookup-my-cluster-es-http-on-1xx-xx-xx-xx-no-such-host/260172
**Category:** Beats
**Tags:** filebeat
**Created:** [January 5, 2021, 7:30am UTC](https://discuss.elastic.co/t/dns-lookup-failure-my-cluster-es-http-lookup-my-cluster-es-http-on-1xx-xx-xx-xx-no-such-host/260172 "2021-01-05T07:30:27Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![umen](https://avatars.discourse-cdn.com/v4/letter/u/ec9cab/32.png) [@umen](https://discuss.elastic.co/u/umen)
#### Post date: [January 5, 2021, 7:30am UTC](https://discuss.elastic.co/t/dns-lookup-failure-my-cluster-es-http-lookup-my-cluster-es-http-on-1xx-xx-xx-xx-no-such-host/260172/1 "2021-01-05T07:30:27Z")

</div>

Hey  
i followed the quickstart tutorial to setup elasticsearch on Kubernetes .  
installed it on pre created namespace not default .

```auto
apiVersion: elasticsearch.k8s.elastic.co/v1
kind: Elasticsearch
metadata:
  name: my-cluster
  namespace: test-cluster
spec:
  version: 7.10.1
  nodeSets:
  - name: default
    count: 3
    config:
      node.master: true
      node.data: true
      node.ingest: true
      node.store.allow_mmap: false

```

now in filebeat-kubernetes.yaml i set :

```auto
env:
        - name: ELASTICSEARCH_HOST
          value: my-cluster-es-http
        - name: ELASTICSEARCH_PORT
          value: "9200"
        - name: ELASTICSEARCH_USERNAME
          value: elastic
        - name: ELASTICSEARCH_PASSWORD
          value: xxxxxxxxx
        - name: ELASTIC_CLOUD_ID
          value: 

```

when i do port forwarding :  
kubectl port-forward service/my-cluster-es-http 9200 -n test-cluster

it connect successfully,  
when i do  
curl -u "elastic:xxxxxxI" -k "[https://localhost:9200](https://localhost:9200)"  
I'm getting :

```auto
{
  "name" : "my-cluster-es-default-0",
  "cluster_name" : "my-cluster",
  "cluster_uuid" : "fAD43yyaxxxmMTJ-eNVQ",
  "version" : {
    "number" : "7.10.1",
    "build_flavor" : "default",
    "build_type" : "docker",
    "build_hash" : "1c34507e6xxxf66f3513706fdf548736aa",
    "build_date" : "2020-12-05T01:00:33.671820Z",
    "build_snapshot" : false,
    "lucene_version" : "8.7.0",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },
  "tagline" : "You Know, for Search"
}

```

But when i do the curl from pod to pod

```auto
curl -u "elastic:xxxxxx" -k "https://my-cluster-es-http:9200"

```

I'm getting :

```auto
Could not resolve host: my-cluster-es-http

```

but when i look into one of the filebeat pods I'm getting :

```auto
WARN	[transport]	transport/tcp.go:52	DNS lookup failure "my-cluster-es-http": lookup my-cluster-es-http on 1xx.xx.xx.xx:53: no such host
2021-01-05T07:14:42.235Z	INFO	[monitoring]	log/log.go:145	Non-zero metrics in the last 30s	{"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":400,"time":{"ms":3}},"total":{"ticks":2320,"time":{"ms":20},"value":2320},"user":{"ticks":1920,"time":{"ms":17}}},"handles":{"limit":{"hard":1048576,"soft":1048576},"open":18},"info":{"ephemeral_id":"73c04f40-060f-414c-9609-6ce2994a4b45","uptime":{"ms":1410067}},"memstats":{"gc_next":62182912,"memory_alloc":32397640,"memory_total":129484856},"runtime":{"goroutines":83}},"filebeat":{"harvester":{"open_files":8,"running":17}},"libbeat":{"config":{"module":{"running":0}},"pipeline":{"clients":1,"events":{"active":4117,"retry":50}}},"registrar":{"states":{"current":7}},"system":{"load":{"1":0.31,"15":0.14,"5":0.26,"norm":{"1":0.0388,"15":0.0175,"5":0.0325}}}}}}
2021-01-05T07:15:06.918Z	ERROR	[publisher_pipeline_output]	pipeline/output.go:154	Failed to connect to backoff(elasticsearch(http://my-cluster-es-http:9200)): Get "http://my-cluster-es-http:9200": lookup my-cluster-es-http on 1xx.xx.xx.xx:53: no such host
2021-01-05T07:15:06.919Z	INFO	[publisher_pipeline_output]	pipeline/output.go:145	Attempting to reconnect to backoff(elasticsearch(http://my-cluster-es-http:9200)) with 37 reconnect attempt(s)
2021-01-05T07:15:06.919Z	INFO	[publisher]	pipeline/retry.go:219	retryer: send unwait signal to consumer

```

Therefore not getting anything in kibana  
what I'm missing here ?  
Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 2, 2021, 9:30am UTC](https://discuss.elastic.co/t/dns-lookup-failure-my-cluster-es-http-lookup-my-cluster-es-http-on-1xx-xx-xx-xx-no-such-host/260172/2 "2021-02-02T09:30:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
