# Docker and Kubernetes problem with connecting to Elasticsearch

**URL:** <https://discuss.elastic.co/t/docker-and-kubernetes-problem-with-connecting-to-elasticsearch/213129>\
**Category:** Elastic Search\
**Tags:** docker, elastic-app-search\
**Created:** [December 27, 2019, 5:09am UTC](https://discuss.elastic.co/t/docker-and-kubernetes-problem-with-connecting-to-elasticsearch/213129 "2019-12-27T05:09:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![byteandbit](https://avatars.discourse-cdn.com/v4/letter/b/f05b48/32.png) [@byteandbit](https://discuss.elastic.co/u/byteandbit)\
**Post date:** [December 27, 2019, 5:09am UTC](https://discuss.elastic.co/t/docker-and-kubernetes-problem-with-connecting-to-elasticsearch/213129/1 "2019-12-27T05:09:51Z")

</div>

Where I can find configuration documentation for docker images for:  
[docker.elastic.co/app-search/app-search:7.5.1](http://docker.elastic.co/app-search/app-search:7.5.1) ? I am not sure how to configure app search docker image to connect to ES within Kubernetes cluster.

I am getting following error on startup:

> Blockquote  
> Error: App Search is unable to connect to Elasticsearch. Ensure a healthy Elasticsearch cluster is running at [http://quickstart-es-default:9200](http://quickstart-es-default:9200) for user elastic.  
> Blockquote

The [http://quickstart-es-default:9200](http://quickstart-es-default:9200) is correct address and I can successfully do following:  
curl -u "elastic:somepassword" -k "[https://quickstart-es-default:9200](https://quickstart-es-default:9200)" from any node in the cluster.

thanks

---

<div class="post-metadata">

**Author:** ![byteandbit](https://avatars.discourse-cdn.com/v4/letter/b/f05b48/32.png) [@byteandbit](https://discuss.elastic.co/u/byteandbit)\
**Post date:** [December 27, 2019, 8:55pm UTC](https://discuss.elastic.co/t/docker-and-kubernetes-problem-with-connecting-to-elasticsearch/213129/2 "2019-12-27T20:55:55Z")

</div>

Solved! Had to configure app search to use ssl (ca, ce, and key).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 24, 2020, 8:55pm UTC](https://discuss.elastic.co/t/docker-and-kubernetes-problem-with-connecting-to-elasticsearch/213129/3 "2020-01-24T20:55:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
