# Docker elasticsearch container : FileSystemException : Not a directory

**URL:** <https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [June 16, 2023, 8:04am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196 "2023-06-16T08:04:04Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![JulianMeister](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julianmeister/32/122311_2.png) [@JulianMeister](https://discuss.elastic.co/u/JulianMeister)\
**Post date:** [June 16, 2023, 8:04am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196/1 "2023-06-16T08:04:04Z")

</div>

I have the same issue as described in:

> [@Docker elasticsearch container : FileSystemException : Not a directory](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/330204):
>
> I tried to modify the port the docker container of elasticsearch from 9200:9200 to 9201:9200 and since I did that I got this error in the docker container : "message": "uncaught exception in thread [main]", "stacktrace": ["org.elasticsearch.bootstrap.StartupException: ElasticsearchException[failed to bind service]; nested: FileSystemException[/usr/share/elasticsearch/data/nodes/0: Not a directory];", "at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:171) ~[elasticsearch-7.1…

I'm getting the error  
"java.nio.file.FileSystemException: /usr/share/elasticsearch/data/nodes/0: Not a directory"

But if I change "/usr/share/elasticsearch/data" to "/usr/share/elasticsearch", I instead receive this error:  
"/usr/local/bin/docker-entrypoint.sh: line 49: /usr/share/elasticsearch/bin/elasticsearch-env-from-file: No such file or directory"

@JackieLaFrite Have you been able to find a solution/workaround for this problem yet by any chance?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [June 16, 2023, 8:34am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196/2 "2023-06-16T08:34:39Z")

</div>

> [@JulianMeister](#):
>
> `/usr/share/elasticsearch/data/nodes/0: Not a directory`

Is this message accurate? I.e. is this path a file and not a directory? If it's a file, what are its contents?

---

<div class="post-metadata">

**Author:** ![JulianMeister](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julianmeister/32/122311_2.png) [@JulianMeister](https://discuss.elastic.co/u/JulianMeister)\
**Post date:** [June 16, 2023, 9:08am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196/3 "2023-06-16T09:08:35Z")

</div>

It doesn't exist, the path stops right after /usr/share/elasticsearch/data .  
However, I can also not create the directory as the container just shuts itself down again immediately after reaching this error.  
I realized this when I inspected the container by starting it via  
docker run -it --entrypoint /bin/bash 'elasticsearch:7.13.4'  
instead of  
docker-compose up -d  
I can't start up my entire project that way though, so I can't create the directory on a live container.

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [June 16, 2023, 9:27am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196/4 "2023-06-16T09:27:14Z")

</div>

Hmm I think you're not seeing what Elasticsearch is seeing. It would create this directory if it doesn't exist at all.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 14, 2023, 9:27am UTC](https://discuss.elastic.co/t/docker-elasticsearch-container-filesystemexception-not-a-directory/336196/5 "2023-07-14T09:27:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
