# Docker Elasticsearch failing

**URL:** https://discuss.elastic.co/t/docker-elasticsearch-failing/247686
**Category:** Elasticsearch
**Tags:** docker
**Created:** [September 6, 2020, 8:25pm UTC](https://discuss.elastic.co/t/docker-elasticsearch-failing/247686 "2020-09-06T20:25:54Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![tamilarasanbravo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tamilarasanbravo/32/62962_2.png) [@tamilarasanbravo](https://discuss.elastic.co/u/tamilarasanbravo)
#### Post date: [September 6, 2020, 8:25pm UTC](https://discuss.elastic.co/t/docker-elasticsearch-failing/247686/1 "2020-09-06T20:25:54Z")

</div>

Hi Team,

I have created a 3 node elasticsearch setup. One of my docker container fails with the below error

```auto
lasticsearch/config/roles.yml]" }
{"type": "server", "timestamp": "2020-09-06T20:23:28,362Z", "level": "INFO", "component": "o.e.d.DiscoveryModule", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "using discovery type [zen] and seed hosts providers [settings]" }
{"type": "server", "timestamp": "2020-09-06T20:23:28,755Z", "level": "WARN", "component": "o.e.g.DanglingIndicesState", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,130Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "initialized" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,131Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "starting ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,249Z", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "publish_address {10.0.0.193:9300}, bound_addresses {0.0.0.0:9300}" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,388Z", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }
ERROR: [1] bootstrap checks failed
[1]: initial heap size [2136997888] not equal to maximum heap size [2147483648]; this can cause resize pauses
ERROR: Elasticsearch did not exit normally - check the logs at /usr/share/elasticsearch/logs/docker-cluster.log
{"type": "server", "timestamp": "2020-09-06T20:23:29,395Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "stopping ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,405Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "stopped" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,405Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "closing ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,416Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "closed" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,417Z", "level": "INFO", "component": "o.e.x.m.p.NativeController", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "Native controller process has stopped - no new native processes can be started" }

```

Please help me understand the reason.

Regards  
TJ

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [September 6, 2020, 8:39pm UTC](https://discuss.elastic.co/t/docker-elasticsearch-failing/247686/2 "2020-09-06T20:39:15Z")

</div>

Hi @tamilarasanbravo

It usually helps to post your config files / docker compose etc..

The error seems to indicate that the JVM heap settings are not equal.

[https://www.elastic.co/guide/en/elasticsearch/reference/current/heap-size.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/heap-size.html)

Elasticsearch will assign the entire heap specified in [jvm.options](https://www.elastic.co/guide/en/elasticsearch/reference/current/jvm-options.html) via the `Xms` (minimum heap size) and `Xmx` (maximum heap size) settings. You should set these two settings to be equal to each other.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 4, 2020, 8:39pm UTC](https://discuss.elastic.co/t/docker-elasticsearch-failing/247686/3 "2020-10-04T20:39:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
