# (Docker) how to run ES on a docker hoster?

**URL:** https://discuss.elastic.co/t/docker-how-to-run-es-on-a-docker-hoster/73857
**Category:** Elasticsearch
**Created:** [February 3, 2017, 1:22pm UTC](https://discuss.elastic.co/t/docker-how-to-run-es-on-a-docker-hoster/73857 "2017-02-03T13:22:49Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![thinking23487](https://avatars.discourse-cdn.com/v4/letter/t/85e7bf/32.png) [@thinking23487](https://discuss.elastic.co/u/thinking23487)
#### Post date: [February 3, 2017, 1:22pm UTC](https://discuss.elastic.co/t/docker-how-to-run-es-on-a-docker-hoster/73857/1 "2017-02-03T13:22:49Z")

</div>

Hi all,

i'm trying to run ES on a docker hosting service provider and have the problem that the container doesnt start cause of bootstrap checks:  
[2017-02-03T13:10:31,019][INFO][o.e.t.TransportService] [dkejAzL] publish\_address {172.17.0.2:9300}, bound\_addresses {[::]:9300}  
[2017-02-03T13:10:31,030][INFO][o.e.b.BootstrapChecks] [dkejAzL] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
ERROR: bootstrap checks failed  
max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]

A few days ago it seems this has been solved, but i dont get it running.  
[This](https://github.com/docker-library/elasticsearch/issues/98) issue states that the container should run anywhere without problems by running locally on my dev box:  
docker run -d --name elas elasticsearch -Etransport.host=0.0.0.0 -Ediscovery.zen.minimum\_master\_nodes=1

I got the same problem as the docker hoster, the boostrap checks fail and i cannot change vm.max\_map\_count cause i dont have access to the host where the container will run.  
Did i do anything wrong? The issue mentioned that it has been solved, but i dont get it running. Any hints on the next step to try?

thx

---

<div class="post-metadata">

### Author: ![tanguy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tanguy/32/6030_2.png) [@tanguy](https://discuss.elastic.co/u/tanguy)
#### Post date: [February 3, 2017, 3:49pm UTC](https://discuss.elastic.co/t/docker-how-to-run-es-on-a-docker-hoster/73857/2 "2017-02-03T15:49:03Z")

</div>

Hi,

Did you try the official docker image by Elastic [https://github.com/elastic/elasticsearch-docker](https://github.com/elastic/elasticsearch-docker)?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 3, 2017, 3:49pm UTC](https://discuss.elastic.co/t/docker-how-to-run-es-on-a-docker-hoster/73857/3 "2017-03-03T15:49:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
