# Docker kibana plugin installation with external dependencies error

**URL:** <https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [September 20, 2019, 3:30pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451 "2019-09-20T15:30:38Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Artem\_Kuznetsov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/artem_kuznetsov/32/54615_2.png) [@Artem\_Kuznetsov](https://discuss.elastic.co/u/Artem_Kuznetsov)\
**Post date:** [September 20, 2019, 3:30pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451/1 "2019-09-20T15:30:38Z")

</div>

Hey!

I try to install our plugin with external dependencies([https://www.ag-grid.com/](https://www.ag-grid.com/)) using Kibana docker image. I tried 7.3.0 and 7.3.1  
On local machine I could install the plugin by coping it builded code to the plugins folder and running kibana with  
bin/kibana -plugin-path='home\_dir/plugins/my\_plugin'

This approach doesn't work with docker.

Here is the error I've got:

> ```
> kibana_1 | {"type":"log","@timestamp":"2019-09-20T14:59:08Z","tags":["info","optimize"],"pid":1,"message":"Optimizing and caching bundles for graph, monitoring, space_selector, login, overwritten_session, logout, logged_out, ml, dashboardViewer, apm, code, maps, canvas, infra, siem, uptime, biei_73, kibana, stateSessionStorageRedirect, status_page and timelion. This may take a few minutes"}
> kibana_1 | events.js:174
> kibana_1 | throw er; // Unhandled 'error' event
> kibana_1 | ^
> kibana_1 | 
> kibana_1 | Error: write EPIPE
> kibana_1 | at WriteWrap.afterWrite (net.js:782:14)
> kibana_1 | Emitted 'error' event at:
> kibana_1 | at onwriteError (_stream_writable.js:431:12)
> kibana_1 | at onwrite (_stream_writable.js:456:5)
> kibana_1 | at _destroy (internal/streams/destroy.js:40:7)
> kibana_1 | at Socket._destroy (net.js:607:3)
> kibana_1 | at Socket.destroy (internal/streams/destroy.js:32:8)
> kibana_1 | at WriteWrap.afterWrite (net.js:784:10)
> biei_73_kibana_1 exited with code 1
> 
> ```

I built kibana with plugin image

> FROM kibana:7.3.0  
> ENV PATH /usr/share/kibana/bin:$PATH  
> COPY --chown=kibana build/my\_plugin /usr/share/kibana/plugins/my\_plugin

My compose file:

> ```
> version: '3'
> 
> services:
> elasticsearch:
> image: docker.elastic.co/elasticsearch/elasticsearch:7.3.0
> environment:
> - cluster.name=docker-cluster
> - bootstrap.memory_lock=true
> - "ES_JAVA_OPTS=-Xms512m -Xmx512m"
> - discovery.type=single-node
> ulimits:
> memlock:
> soft: -1
> hard: -1
> ports:
> - "9200:9200"
> kibana:
> image: kibana_browser:0.2.0
> ports:
> - "5601:5601"
> command: /usr/share/kibana/bin/kibana --plugin-path=/usr/share/kibana/plugins/my_plugin
> 
> ```

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [September 20, 2019, 9:56pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451/2 "2019-09-20T21:56:36Z")

</div>

I'm not sure what that error means. Can you try adding the `--verbose` option to your command? Maybe you can get more details.

---

<div class="post-metadata">

**Author:** ![Artem\_Kuznetsov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/artem_kuznetsov/32/54615_2.png) [@Artem\_Kuznetsov](https://discuss.elastic.co/u/Artem_Kuznetsov)\
**Post date:** [September 24, 2019, 1:28pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451/3 "2019-09-24T13:28:37Z")

</div>

Here is the output with verbose added:

[https://pastebin.com/R1fHBf59](https://pastebin.com/R1fHBf59)

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [September 24, 2019, 9:18pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451/4 "2019-09-24T21:18:59Z")

</div>

> [@Artem\_Kuznetsov](#):
>
> Error: write EPIPE

The verbose logs did not help much. I wonder if you can increase the available memory in your container? Someone had a similar error and said increasing the memory resolved it. [Error: write EPIPE at WriteWrap.afterWrite · Issue #1652 · nodejs/help · GitHub](https://github.com/nodejs/help/issues/1652#issuecomment-471023500)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2019, 9:19pm UTC](https://discuss.elastic.co/t/docker-kibana-plugin-installation-with-external-dependencies-error/200451/5 "2019-10-22T21:19:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
