# Docker + Persistent Registry = autodiscover failing

**URL:** https://discuss.elastic.co/t/docker-persistent-registry-autodiscover-failing/157688
**Category:** Beats
**Tags:** filebeat
**Created:** [November 21, 2018, 11:10am UTC](https://discuss.elastic.co/t/docker-persistent-registry-autodiscover-failing/157688 "2018-11-21T11:10:10Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![lifeofguenter](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lifeofguenter/32/17384_2.png) [@lifeofguenter](https://discuss.elastic.co/u/lifeofguenter)
#### Post date: [November 22, 2018, 10:49am UTC](https://discuss.elastic.co/t/docker-persistent-registry-autodiscover-failing/157688/4 "2018-11-22T10:49:17Z")

</div>

seems to be independent of having a persistent registry. but for some reason using this `docker-compose.yml` will sometimes fail with the above error:

```auto
version: '3.7'

services:
  redis:
    image: redis:3.2-alpine
    container_name: logs-logstash_redis

  logstash:
    image: docker.elastic.co/logstash/logstash:6.5.1
    depends_on:
      - redis
    environment:
      REDIS_HOST: redis
    entrypoint: /usr/local/bin/custom-entrypoint.sh

  filebeat:
    image: docker.elastic.co/beats/filebeat:6.5.1
    command:
      - -e
      - -strict.perms=false
    depends_on:
      - logstash
    environment:
      REDIS_HOST: redis
    volumes:
      - /var/log:/var/hostlog:ro
      - /var/lib/docker/containers:/var/lib/docker/containers:ro
      - /var/run/docker.sock:/var/run/docker.sock

  # only needed to generate logs
  nginx:
    image: nginx:1.14-alpine
    container_name: logs-logstash_nginx
    depends_on:
      - filebeat
    ports:
      - '127.0.0.1:8181:80'
    volumes:
      - ${PWD}/nginx.conf:/etc/nginx/nginx.conf:ro
    labels:
      com.foobar.logs.type: nginx

```

---

_[View the full topic](https://discuss.elastic.co/t/docker-persistent-registry-autodiscover-failing/157688)._
