# Docker pull of 5.1.2 fails with Client.Timeout exceeded while awaiting headers

**URL:** <https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555>\
**Category:** Elasticsearch\
**Created:** [January 13, 2017, 6:18pm UTC](https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555 "2017-01-13T18:18:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![gertd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gertd/32/14560_2.png) [@gertd](https://discuss.elastic.co/u/gertd)\
**Post date:** [January 13, 2017, 6:18pm UTC](https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555/1 "2017-01-13T18:18:28Z")

</div>

Hi all,

When trying to pull the 5.1,2 docker image I am getting a failure Client.Timeout exceeded while awaiting headers

PS C:\> docker pull [docker.elastic.co/elasticsearch/elasticsearch:5.1.2](http://docker.elastic.co/elasticsearch/elasticsearch:5.1.2)  
Error response from daemon: Get [https://docker.elastic.co/v2/elasticsearch/elasticsearch/manifests/5.1.2:](https://docker.elastic.co/v2/elasticsearch/elasticsearch/manifests/5.1.2:) Get [https://co](https://co)  
[ntainer-registry.elastic.co:7000/auth?scope=repository%3Aelasticsearch%2Felasticsearch%3Apull&service=token-service:](http://ntainer-registry.elastic.co:7000/auth?scope=repository%3Aelasticsearch%2Felasticsearch%3Apull&service=token-service:) net  
/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Pulling from the docker hub works.

Any suggestions?

PS C:\> docker info  
Containers: 0  
Running: 0  
Paused: 0  
Stopped: 0  
Images: 1  
Server Version: 1.12.6  
Storage Driver: aufs  
Root Dir: /var/lib/docker/aufs  
Backing Filesystem: extfs  
Dirs: 18  
Dirperm1 Supported: true  
Logging Driver: json-file  
Cgroup Driver: cgroupfs  
Plugins:  
Volume: local  
Network: overlay null host bridge  
Swarm: inactive  
Runtimes: runc  
Default Runtime: runc  
Security Options: seccomp  
Kernel Version: 4.4.41-moby  
Operating System: Alpine Linux v3.4  
OSType: linux  
Architecture: x86\_64  
CPUs: 2  
Total Memory: 1.919 GiB  
Name: moby  
ID: HU53:RARP:YERG:EHQF:ASBG:25PD:6LTP:C4GL:DWI7:WUL4:NLGP:HJGH  
Docker Root Dir: /var/lib/docker  
Debug Mode (client): false  
Debug Mode (server): true  
File Descriptors: 13  
Goroutines: 22  
System Time: 2017-01-13T18:17:34.2370698Z  
EventsListeners: 0  
Registry: [https://index.docker.io/v1/](https://index.docker.io/v1/)  
WARNING: No kernel memory limit support  
Insecure Registries:  
127.0.0.0/8

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [January 13, 2017, 7:20pm UTC](https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555/2 "2017-01-13T19:20:40Z")

</div>

I had no issues pulling the image just now. Would you mind trying again?

---

<div class="post-metadata">

**Author:** ![gertd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gertd/32/14560_2.png) [@gertd](https://discuss.elastic.co/u/gertd)\
**Post date:** [January 13, 2017, 9:31pm UTC](https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555/3 "2017-01-13T21:31:08Z")

</div>

Seems to be related to running a Windows host, my Mac does not have the problem. On Windows the problem persists though.

"docker pull eleasticsearch" runs just fine on Windows and am I able to run 5.1.1 that way as a container.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 10, 2017, 9:31pm UTC](https://discuss.elastic.co/t/docker-pull-of-5-1-2-fails-with-client-timeout-exceeded-while-awaiting-headers/71555/4 "2017-02-10T21:31:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
