# Does not have the remote cluster client role enabled\[Elasticserach, Kibana\]

**URL:** <https://discuss.elastic.co/t/does-not-have-the-remote-cluster-client-role-enabled-elasticserach-kibana/336671>\
**Category:** Kibana\
**Created:** [June 22, 2023, 10:52am UTC](https://discuss.elastic.co/t/does-not-have-the-remote-cluster-client-role-enabled-elasticserach-kibana/336671 "2023-06-22T10:52:19Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Resul\_Zoroglu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/resul_zoroglu/32/119499_2.png) [@Resul\_Zoroglu](https://discuss.elastic.co/u/Resul_Zoroglu)\
**Post date:** [June 22, 2023, 10:52am UTC](https://discuss.elastic.co/t/does-not-have-the-remote-cluster-client-role-enabled-elasticserach-kibana/336671/1 "2023-06-22T10:52:19Z")

</div>

@dylan0911  
I'm getting the following error on kibana, you have solved the problem before. what exactly do you do for solution

your topic

> [@This node does not have the remote\_cluster\_client role](https://discuss.elastic.co/t/this-node-does-not-have-the-remote-cluster-client-role/266294):
>
> Hi all, Been going through the doc, the topics and github. Can't seem to find an answer tho this one. I have 2 clusters running in 2 different regions and wanted to test CCR. Both of them are running on 7.11.1. I was able to setup the remote clusters on both of them and can even do cross cluster searching on them. However, when I try to configure the cross cluster replication, I get the following error in Kibana: Also tried it through the API: {"error…

```auto
[ERROR][http] ResponseError: illegal_argument_exception
        Root causes:
                illegal_argument_exception: node [elasticsearch-client] does not have the remote cluster client role enabled
    at KibanaTransport.request (/usr/share/kibana/node_modules/@elastic/transport/lib/Transport.js:479:27)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at KibanaTransport.request (/usr/share/kibana/node_modules/@kbn/core-elasticsearch-client-server-internal/src/create_transport.js:51:16)
    at Indices.resolveIndex (/usr/share/kibana/node_modules/@elastic/elasticsearch/lib/api/api/indices.js:1059:16)
    at /usr/share/kibana/src/plugins/data_view_management/server/routes/resolve_index.js:29:18
    at Router.handle (/usr/share/kibana/node_modules/@kbn/core-http-router-server-internal/src/router.js:141:30)
    at handler (/usr/share/kibana/node_modules/@kbn/core-http-router-server-internal/src/router.js:107:50)
    at exports.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:60:28)
    at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:371:32)
    at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:281:9)

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 20, 2023, 10:53am UTC](https://discuss.elastic.co/t/does-not-have-the-remote-cluster-client-role-enabled-elasticserach-kibana/336671/2 "2023-07-20T10:53:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
