# Doker run dometricbeat:8.17.0 failed

**URL:** <https://discuss.elastic.co/t/doker-run-dometricbeat-8-17-0-failed/374258>\
**Category:** Metrics\
**Created:** [February 8, 2025, 11:24am UTC](https://discuss.elastic.co/t/doker-run-dometricbeat-8-17-0-failed/374258 "2025-02-08T11:24:06Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Resoft-190910](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/resoft-190910/32/141243_2.png) [@Resoft-190910](https://discuss.elastic.co/u/Resoft-190910)\
**Post date:** [February 8, 2025, 11:24am UTC](https://discuss.elastic.co/t/doker-run-dometricbeat-8-17-0-failed/374258/1 "2025-02-08T11:24:06Z")

</div>

This is execute command:

docker run --network elk elastic/metricbeat:8.17.0 setup -E setup.ilm.overwrite=true -E setup.kibana.host=kibana:5601 -E output.elasticsearch.hosts=["xxxxxxxxx:9200"] -E output.elasticsearch.username=elastic -E output.elasticsearch.password=wl123456

But it failed, kibana and elasticsearch is healthy

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
SDK 2025/02/08 11:19:13 WARN falling back to IMDSv1: operation error ec2imds: getToken, http response error StatusCode: 404, request to EC2 IMDS failed
