# Don't run curator (curator.exceptions.ConfigurationError: Unable to parse YAML file. Error)

**URL:** <https://discuss.elastic.co/t/dont-run-curator-curator-exceptions-configurationerror-unable-to-parse-yaml-file-error/100487>\
**Category:** Elasticsearch\
**Created:** [September 14, 2017, 8:49am UTC](https://discuss.elastic.co/t/dont-run-curator-curator-exceptions-configurationerror-unable-to-parse-yaml-file-error/100487 "2017-09-14T08:49:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rchumarin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rchumarin/32/23456_2.png) [@rchumarin](https://discuss.elastic.co/u/rchumarin)\
**Post date:** [September 14, 2017, 8:49am UTC](https://discuss.elastic.co/t/dont-run-curator-curator-exceptions-configurationerror-unable-to-parse-yaml-file-error/100487/1 "2017-09-14T08:49:06Z")

</div>

Hello.

action.yml:  
---  
actions:  
1:  
action: delete\_indices  
description: \>-  
Delete indices older than {{ elk.elasticsearch.age\_of\_index }} days (based on index name)  
options:  
ignore\_empty\_list: True  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: {{ elk.logstash.index }}-\*  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: {{ elk.elasticsearch.age\_of\_index }}  
2:  
action: delete\_indices  
description: \>-  
Delete indices more than N Gb  
options:  
ignore\_empty\_list: True  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: {{ elk.logstash.index }}-\*  
- filtertype: space  
disk\_space: {{ elk.curator.size }}  
use\_age: True  
source: creation\_date  
timestring:  
field:  
stats\_result:  
exclude:

curator.yml:  
---  
client:  
hosts:  
- elasticsearch  
port: 9200  
url\_prefix:  
use\_ssl: False  
certificate:  
client\_cert:  
client\_key:  
ssl\_no\_validate: False  
http\_auth:  
timeout: 30  
master\_only: False

logging:  
loglevel: INFO  
logfile:  
logformat: default  
blacklist:

Don't run docker container with curator. What is the problem? How to fix the error?

* * *

Configuration 1 in file action.yml is working. When configuration 2 is added, then the error is:  
Docker logs curator:  
...  
{"log":" File "/usr/local/lib/python2.7/site-packages/click/core.py", line 535, in invoke\n","stream":"stderr","time":"2017-09-14T07:56:52.732340712Z"}  
{"log":" return callback(\*args, \*\*kwargs)\n","stream":"stderr","time":"2017-09-14T07:56:52.732495754Z"}  
{"log":" File "/usr/local/lib/python2.7/site-packages/curator/cli.py", line 126, in cli\n","stream":"stderr","time":"2017-09-14T07:56:52.73250445Z"}  
{"log":" action\_config = get\_yaml(action\_file)\n","stream":"stderr","time":"2017-09-14T07:56:52.732507669Z"}  
{"log":" File "/usr/local/lib/python2.7/site-packages/curator/utils.py", line 56, in get\_yaml\n","stream":"stderr","time":"2017-09-14T07:56:52.73251033Z"}  
{"log":" 'Unable to parse YAML file. Error: {0}'.format(e))\n","stream":"stderr","time":"2017-09-14T07:56:52.732513204Z"}  
{"log":"curator.exceptions.ConfigurationError: Unable to parse YAML file. Error: while scanning for the next token\n","stream":"stderr","time":"2017-09-14T07:56:52.732576271Z"}  
{"log":"found character '\t' that cannot start any token\n","stream":"stderr","time":"2017-09-14T07:56:52.7325886Z"}  
{"log":" in "\u003cstring\u003e", line 24, column 1:\n","stream":"stderr","time":"2017-09-14T07:56:52.732591507Z"}  
{"log":" \u0009options:\n","stream":"stderr","time":"2017-09-14T07:56:52.732594561Z"}  
{"log":" ^\n","stream":"stderr","time":"2017-09-14T07:56:52.73259723Z"}

---

<div class="post-metadata">

**Author:** ![rchumarin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rchumarin/32/23456_2.png) [@rchumarin](https://discuss.elastic.co/u/rchumarin)\
**Post date:** [September 15, 2017, 6:59am UTC](https://discuss.elastic.co/t/dont-run-curator-curator-exceptions-configurationerror-unable-to-parse-yaml-file-error/100487/3 "2017-09-15T06:59:02Z")

</div>

The error was eliminated. The problem was in tabulation in the action.yml

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2017, 6:59am UTC](https://discuss.elastic.co/t/dont-run-curator-curator-exceptions-configurationerror-unable-to-parse-yaml-file-error/100487/4 "2017-10-13T06:59:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
