# Downgrade from 5.0.0-alpha to 2.4.1 Fails

**URL:** https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024
**Category:** Elasticsearch
**Created:** [October 14, 2016, 6:56am UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024 "2016-10-14T06:56:54Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Kobi\_Jacobson](https://avatars.discourse-cdn.com/v4/letter/k/d26b3c/32.png) [@Kobi\_Jacobson](https://discuss.elastic.co/u/Kobi_Jacobson)
#### Post date: [October 14, 2016, 6:56am UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024/1 "2016-10-14T06:56:54Z")

</div>

Installed 5.0.0-alpha on CentOS 7 (VirtualBox) which worked ok but I had some issues with the JAVA API documentation. Tried to downgrade to 2.4.1 and when ES starts I get the following error (appears on the cluster log file:

```
[2016-10-14 09:40:11,830][INFO][node] [kobi-node] version[2.4.1], pid[4420], bui
ld[c67dc32/2016-09-27T18:57:55Z]
[2016-10-14 09:40:11,848][INFO][node] [kobi-node] initializing ...
[2016-10-14 09:40:11,862][ERROR][bootstrap] Exception
java.lang.IllegalStateException: Unable to initialize modules
	at org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:121)
	at org.elasticsearch.node.Node.<init>(Node.java:158)
	at org.elasticsearch.node.Node.<init>(Node.java:140)
	at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143)
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:194)
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286)
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
Caused by: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/modules/aggs-matrix-stats/plugi
n-descriptor.properties
	at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
	at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214)
	at java.nio.file.Files.newByteChannel(Files.java:361)
	at java.nio.file.Files.newByteChannel(Files.java:407)
	at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384)
	at java.nio.file.Files.newInputStream(Files.java:152)
	at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:87)
	at org.elasticsearch.plugins.PluginsService.getModuleBundles(PluginsService.java:335)
	at org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:114)
	... 6 more

```

I tried to list my plugins and there are none. Also both "modules" and "plugins" folders are empty under /usr/share/elasticsearch. Any ideas?

Thanks,  
Kobi

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [October 14, 2016, 7:16am UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024/2 "2016-10-14T07:16:03Z")

</div>

Reinstall completely a fresh new version You can not downgrade.

Here internal modules 5.0 are not compatible with modules 2.x.

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [October 14, 2016, 7:17am UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024/3 "2016-10-14T07:17:06Z")

</div>

Hey,

can you uninstall the 5.0 version AND delete the `/usr/share/elasticsearch/modules/` directory by hand. Then install 2.4 - seems there are some leftover from 5.0...

--Alex

---

<div class="post-metadata">

### Author: ![Kobi\_Jacobson](https://avatars.discourse-cdn.com/v4/letter/k/d26b3c/32.png) [@Kobi\_Jacobson](https://discuss.elastic.co/u/Kobi_Jacobson)
#### Post date: [October 14, 2016, 7:43am UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024/4 "2016-10-14T07:43:25Z")

</div>

Thanks for the tip.  
Decided to uninstall and remove any relevant leftover folders altogether. Then re-installed 2.4.1 - Seems to do the trick.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:12pm UTC](https://discuss.elastic.co/t/downgrade-from-5-0-0-alpha-to-2-4-1-fails/63024/5 "2017-07-05T22:12:26Z")

</div>


