# ECE installation failed

**URL:** <https://discuss.elastic.co/t/ece-installation-failed/103197>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [October 9, 2017, 9:07am UTC](https://discuss.elastic.co/t/ece-installation-failed/103197 "2017-10-09T09:07:52Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bala23](https://avatars.discourse-cdn.com/v4/letter/b/da6949/32.png) [@Bala23](https://discuss.elastic.co/u/Bala23)\
**Post date:** [October 9, 2017, 9:07am UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/1 "2017-10-09T09:07:52Z")

</div>

I have getting the following error while Elastic Enterprise .

**_Installation Logs_**

```
  > bash <(curl -fsSL https://download.elastic.co/cloud/elastic-cloud-enterprise.sh) install --debug
> WARNING: Error loading config file:/root/.docker/config.json - stat /root/.docker/config.json: permission denied
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Elastic Cloud Enterprise Installer
> 
> Start setting up a new Elastic Cloud Enterprise installation by installing the software on your first host.
> This first host becomes the initial coordinator and provides access to the Cloud UI, where you can manage your installation.
> To learn more about the options you can specify, see the documentation.
> 
> NOTE: If you want to add this host to an existing installation, please specify the --coordinator-host and --roles-token flags
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
> -- Debug Info --
> NODE_TYPE - initial
> REPOSITORY - docker.elastic.co/cloud-enterprise
> RUNNER_CAPACITY - 8549
> RUNNER_AVAILABILITY_ZONE - ece-region-1a
> NODE_TYPE - initial
> FORCE_INSTALL - False
> HOST_STORAGE_ROOT_VOLUME_PATH - /mnt/data
> RUNNER_ID - 192.168.1.6
> RUNNER_REGION - ece-region
> RUNNER_ROLES -
> ELASTIC_UID - 1000
> HOST_STORAGE_PATH - /mnt/data/elastic
> HOST_PREREQ_FAILED - False
> MEMORY_SETTINGS - {}
> HOST_STORAGE_DEVICE_PATH - /dev/mapper/ubuntu--vg-root
> RUNNER_ROLES_TOKEN -
> RUNNER_HOST_IP - 192.168.1.6
> ELASTIC_GID - 1000
> CLOUD_ENTERPRISE_VERSION - 1.0.2
> 
> -- Verifying Prerequisites --
> Checking host storage path... PASSED
> Checking docker version... PASSED
> - Elastic Cloud Enterprise is certified for 1.11. but 17.03.1-ce is currently installed
> Checking internal ip connectivity... PASSED
> Checking OS settings... PASSED
> Checking OS kernel version... PASSED
> Checking Minimum required memory... PASSED
> Checking Kernel cgroup.memory setting... PASSED
> - OS setting 'cgroup.memory' should be set to cgroup.memory=nokmem
> -- Completed Verifying Prerequisites --
> 
> - Running Bootstrap container
> - Monitoring bootstrap process
> - [2017-10-09 08:51:40,035][INFO][no.found.bootstrap.BootstrapInitial] Loaded bootstrap settings {}
> - [2017-10-09 08:51:47,942][WARN][no.found.docker.DockerContainerManager] Default registry [https://index.docker.io/v1/] has no auths. Known auths: [List()] {}
> - [2017-10-09 08:51:53,395][INFO][no.found.docker.DockerContainerManager] Starting container [frc-zookeeper-servers-zookeeper] {"ec_container_kind":"docker","ec_container_group":"zookeeper-servers","ec_container_name":"zookeeper"}
> .........
> - ) {}
> - [2017-10-09 08:52:07,995][INFO][no.found.bootstrap.BootstrapInitial] Creating container set [curators] with acls: List(31,s{'digest,'runners:f1eruKhHNtuD8c0HDPLAxIyCdnI=}
> - , 31,s{'digest,'curators:IcJELDo2ZtURUqf99CZZhm95/50=}
> - ) {}
> - [2017-10-09 08:52:08,015][INFO][no.found.bootstrap.BootstrapInitial] Starting local runner {}
> - [2017-10-09 08:52:09,671][INFO][no.found.docker.DockerContainerManager] Starting container [frc-runners-runner] {"ec_container_kind":"docker","ec_container_group":"runners","ec_container_name":"runner"}
> - [2017-10-09 08:52:10,039][INFO][no.found.bootstrap.BootstrapInitial] Started local runner {}
> - [2017-10-09 08:52:10,043][INFO][no.found.bootstrap.BootstrapInitial] Waiting for runner container node {}
> - [2017-10-09 08:52:20,197][INFO][no.found.bootstrap.BootstrapInitial] Runner container node detected {}
> - [2017-10-09 08:52:20,661][INFO][no.found.bootstrap.BootstrapInitial] Waiting for coordinator candidate {}
> - [2017-10-09 08:52:45,794][INFO][no.found.curator.ForwardedEnsembleProvider] Resolved connection string from [http://192.168.1.6:2180/zookeeper/clients/ensemble/connection-string?namespace=/v1] to [192.168.1.6:22191/v1] with local namespace [/v1] {}
> - [2017-10-09 08:52:45,796][INFO][org.apache.curator.framework.state.ConnectionStateManager] State change: SUSPENDED {}
> - [2017-10-09 08:52:45,817][ERROR][no.found.bootstrap.BootstrapInitial$] Unhandled error. {}
> -- An error has occurred in bootstrap process. Please examine logs --
> - org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss
> - at no.found.curator.pimps.FutureWatcher.process(FutureWatchables.scala:62)
> - at org.apache.curator.framework.imps.NamespaceWatcher.process(NamespaceWatcher.java:77)
> - at org.apache.zookeeper.ClientCnxn$EventThread.processEvent(ClientCnxn.java:553)
> - at org.apache.zookeeper.ClientCnxn$EventThread.run(ClientCnxn.java:528)
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Errors have caused Elastic Cloud Enterprise installation to fail - Please check logs
> Node type - initial
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Elastic Cloud Enterprise installation completed successfully
> 
> Ready to copy down some important information and keep it safe?
> 
> To access the Cloud UI:
> http://192.168.1.6:12400
> https://192.168.1.6:12443

```

We are not able access the Cloud URL, facing unknown host exception. Any help should be appreciated.

---

<div class="post-metadata">

**Author:** ![Patroklos\_Papapetrou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/patroklos_papapetrou/32/20715_2.png) [@Patroklos\_Papapetrou](https://discuss.elastic.co/u/Patroklos_Papapetrou)\
**Post date:** [October 9, 2017, 9:34am UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/2 "2017-10-09T09:34:31Z")

</div>

Hi @Bala23

Looking at the logs I see a few things that might cause some issues.

1. You are using a docker version that is not officially certified. Can you please use Docker 1.11 instead. If you plan to use Docker 1.12 please have a look at the [documentation](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-prereqs.html)
2. I assume that you've been through the documentation page and you have prepared the right users with proper permissions, right? If not please revisit this [document](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-prereqs.html)

Let's fix the docker issue first and if you still have problems please post here.

Thank you

---

<div class="post-metadata">

**Author:** ![Bala23](https://avatars.discourse-cdn.com/v4/letter/b/da6949/32.png) [@Bala23](https://discuss.elastic.co/u/Bala23)\
**Post date:** [October 9, 2017, 12:46pm UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/3 "2017-10-09T12:46:58Z")

</div>

But my error is on Zookeeper . Can I know how the docker version reflects it and also i am getting a cloud UI and When i connect to the host , it throwing unknown host.

I also could not able to find docker for 1.11 version

---

<div class="post-metadata">

**Author:** ![Patroklos\_Papapetrou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/patroklos_papapetrou/32/20715_2.png) [@Patroklos\_Papapetrou](https://discuss.elastic.co/u/Patroklos_Papapetrou)\
**Post date:** [October 9, 2017, 1:41pm UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/4 "2017-10-09T13:41:37Z")

</div>

Hey @Bala23

I can't tell 100% you if the problem is caused by docker because as I said the version you are using it's not officially supported and it's not tested on our side. My _guess_ is that this is the root cause so please try to follow the installation steps as described in the following links  
[https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-trusty](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-trusty)  
[https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-xenial](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-xenial)  
[https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-rhel-centos](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-configure-hosts.html#ece-install-docker-rhel-centos)

It's on our roadmap to test also ECE installation with docker 1.17 and update our docs accordingly.

---

<div class="post-metadata">

**Author:** ![Bala23](https://avatars.discourse-cdn.com/v4/letter/b/da6949/32.png) [@Bala23](https://discuss.elastic.co/u/Bala23)\
**Post date:** [October 9, 2017, 1:54pm UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/5 "2017-10-09T13:54:03Z")

</div>

I have fixed this issue and also Elastic Cloud Enterprise is running and I can be able to logged into the Elastic cloud UI . Thanks for your help and support.

Now the issue i cant able to create a cluster and I am getting a

"Fetching node configurations failed"(500 Internal Error)

Thanks for your help and support.

---

<div class="post-metadata">

**Author:** ![Patroklos\_Papapetrou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/patroklos_papapetrou/32/20715_2.png) [@Patroklos\_Papapetrou](https://discuss.elastic.co/u/Patroklos_Papapetrou)\
**Post date:** [October 9, 2017, 5:46pm UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/6 "2017-10-09T17:46:33Z")

</div>

Hey @Bala23

Did you solve it by installing ECE using docker 1.11?

---

<div class="post-metadata">

**Author:** ![Bala23](https://avatars.discourse-cdn.com/v4/letter/b/da6949/32.png) [@Bala23](https://discuss.elastic.co/u/Bala23)\
**Post date:** [October 10, 2017, 5:32am UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/7 "2017-10-10T05:32:24Z")

</div>

No . I was using a docker latest version.

I can able to now login to the cloud UI and cannot able to create cluster .

The logs produced in the admin console was,

```
> 2017-10-10 06:48:50,052][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10009ms for sessionid 0xa0003c20fb40010, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,053][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10004ms for sessionid 0xa0003c20fb40016, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,053][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10008ms for sessionid 0xa0003c20fb40015, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,053][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10008ms for sessionid 0xa0003c20fb40013, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,062][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10000ms for sessionid 0xa0003c20fb40011, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,063][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10000ms for sessionid 0xa0003c20fb40017, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,062][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10000ms for sessionid 0xa0003c20fb40012, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,063][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10001ms for sessionid 0xa0003c20fb40014, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,069][INFO][org.apache.zookeeper.ClientCnxn] Client session timed out, have not heard from server in 10005ms for sessionid 0xa0003c20fb40018, closing socket connection and attempting reconnect {}
> [2017-10-10 06:48:50,185][INFO][no.found.curator.ForwardedEnsembleProvider] Resolved connection string from [http://containerhost:2180/zookeeper/clients/ensemble/connection-string?namespace=/v1] to [containerhost:22191/v1] with local namespace [/v1] {}
> [2017-10-10 06:48:50,185][INFO][org.apache.curator.framework.state.ConnectionStateManager] State change: SUSPENDED {}
> [2017-10-10 06:48:50,187][INFO][no.found.curator.ForwardedEnsembleProvider] Resolved connection string from [http://containerhost:2180/zookeeper/clients/ensemble/connection-string?namespace=/v1] to [containerhost:22191/v1] with local namespace [/v1] {}
> [2017-10-10 06:48:50,187][INFO][org.apache.curator.framework.state.ConnectionStateManager] State change: SUSPENDED {}
> [2017-10-10 06:48:50,198][INFO][no.found.curator.ForwardedEnsembleProvider] Resolved connection string from [http://containerhost:2180/zookeeper/clients/ensemble/connection-string?namespace=/v1] to [containerhost:22191/v1] with local namespace [/v1] {}
> [2017-10-10 06:48:50,199][INFO][org.apache.curator.framework.state.ConnectionStateManager] State change
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 24, 2017, 5:32am UTC](https://discuss.elastic.co/t/ece-installation-failed/103197/8 "2017-10-24T05:32:27Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
