# ECE Installation failing, Timeout

**URL:** <https://discuss.elastic.co/t/ece-installation-failing-timeout/158028>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [November 23, 2018, 2:54pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028 "2018-11-23T14:54:02Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![phimob](https://avatars.discourse-cdn.com/v4/letter/p/a3d4f5/32.png) [@phimob](https://discuss.elastic.co/u/phimob)\
**Post date:** [November 23, 2018, 2:54pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/1 "2018-11-23T14:54:02Z")

</div>

Hi,

I'm trying to install ECE on CentOs 7 but it's timing out at "Applying Admin Console Elasticsearch index templates {}"  
I can't make much sense of the log file it's telling me to look at.  
Any help would be appreciated.

I'm running this command:  
bash \<(curl -fsSL [https://download.elastic.co/cloud/elastic-cloud-enterprise.sh](https://download.elastic.co/cloud/elastic-cloud-enterprise.sh)) install

This it the output:

> -- Verifying Prerequisites --  
> Checking runner container does not exist... PASSED  
> Checking host storage root volume path is not root... PASSED  
> Checking host storage path is accessible... PASSED  
> Checking host storage path contents matches whitelist... PASSED  
> Checking Docker version... PASSED  
> Checking Docker file system... PASSED  
> Checking Docker storage driver... PASSED  
> Checking runner ip connectivity... PASSED  
> Checking OS IPv4 IP forward setting... PASSED  
> Checking OS max map count setting... PASSED  
> Checking OS kernel version... PASSED  
> Checking minimum required memory... PASSED  
> Checking OS kernel cgroup.memory... PASSED  
> Checking OS minimum ephemeral port... PASSED  
> Checking OS max open file descriptors per process... PASSED  
> Checking OS max open file descriptors system-wide... PASSED  
> Checking OS file system and Docker storage driver compatibility... PASSED  
> -- Completed Verifying Prerequisites --
> 
> - Running Bootstrap container
> - Monitoring bootstrap process
> - Loaded bootstrap settings {}
> - Initialising feature flag [DedicatedNodeTypes] to [true] {}
> - Starting local runner {}
> - Started local runner {}
> - Waiting for runner container node {}
> - Runner container node detected {}
> - Waiting for coordinator candidate {}
> - Detected coordinator candidate {}
> - Detected pending coordinator, promoting coordinator {}
> - Coordinator accepted {}
> - Storing current platform version: 2.0.0 {}
> - Storing Instance Types: [elasticsearch,kibana] {}
> - Storing Elastic Stack versions: [5.6.12,6.4.1] {}
> - Creating Admin Console Elasticsearch backend {}
> - Applying Admin Console Elasticsearch index templates {}
> - Unhandled error. {}  
> -- An error has occurred in bootstrap process. Please examine logs --  
> java.util.concurrent.TimeoutException: Futures timed out after [600000 milliseconds]  
> at scala.concurrent.impl.Promise$DefaultPromise.ready(Promise.scala:223)  
> at scala.concurrent.impl.Promise$DefaultPromise.result(Promise.scala:227)  
> at scala.concurrent.Await$$anonfun$result$1.apply(package.scala:190)  
> at scala.concurrent.BlockContext$DefaultBlockContext$.blockOn(BlockContext.scala:53)  
> at scala.concurrent.Await$.result(package.scala:190)  
> at no.found.bootstrap.BootstrapInitial.bootstrapServiceLayer(BootstrapInitial.scala:963)  
> at no.found.bootstrap.BootstrapInitial.bootstrap(BootstrapInitial.scala:678)  
> at no.found.bootstrap.BootstrapInitial$.delayedEndpoint$no$found$bootstrap$BootstrapInitial$1(BootstrapInitial.scala:1311)  
> at no.found.bootstrap.BootstrapInitial$delayedInit$body.apply(BootstrapInitial.scala:1305)  
> at scala.Function0$class.apply$mcV$sp(Function0.scala:34)  
> at scala.runtime.AbstractFunction0.apply$mcV$sp(AbstractFunction0.scala:12)  
> at scala.App$$anonfun$main$1.apply(App.scala:76)  
> at scala.App$$anonfun$main$1.apply(App.scala:76)  
> at scala.collection.immutable.List.foreach(List.scala:392)  
> at scala.collection.generic.TraversableForwarder$class.foreach(TraversableForwarder.scala:35)  
> at scala.App$class.main(App.scala:76)  
> at no.found.bootstrap.BootstrapInitial$.main(BootstrapInitial.scala:1305)  
> at no.found.bootstrap.BootstrapInitial.main(BootstrapInitial.scala)
> 
> ```auto
> Errors have caused Elastic Cloud Enterprise installation to fail - Please check logs
> Node type - initial
> 
> ```

---

<div class="post-metadata">

**Author:** ![phimob](https://avatars.discourse-cdn.com/v4/letter/p/a3d4f5/32.png) [@phimob](https://discuss.elastic.co/u/phimob)\
**Post date:** [November 23, 2018, 2:54pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/2 "2018-11-23T14:54:36Z")

</div>

This is the last couple of lines of the log file:

> [2018-11-23 13:10:45,662][INFO][no.found.bootstrap.BootstrapInitial] Creating Admin Console Elasticsearch backend {}  
> [2018-11-23 13:10:48,184][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [ensuring-plan] to complete. Retrying every [1 second] (cause: [org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /clusters/cb1e4ef66659415c8f2320bc3256170d/plans/status]) {}  
> [2018-11-23 13:11:33,214][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [ensuring-plan] to complete. Retrying every [1 second] (cause: [java.lang.Exception: not yet started]) {}  
> [2018-11-23 13:12:09,214][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [ensuring-plan] to complete. Retrying every [1 second] (cause: [org.apache.zookeeper.KeeperException$NodeExistsException: KeeperErrorCode = NodeExists for /clusters/cb1e4ef66659415c8f2320bc3256170d/plans/pending]) {}  
> [2018-11-23 13:12:16,442][INFO][no.found.bootstrap.BootstrapInitial] Applying Admin Console Elasticsearch index templates {}  
> [2018-11-23 13:12:16,567][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [apply-elasticsearch-template] to complete. Retrying every [1 second] (cause: [java.lang.Exception: 410 Gone: HttpEntity(application/json; charset=UTF-8,{"ok":false,"message":"Deleted cluster."})]) {}  
> [2018-11-23 13:12:17,613][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [apply-elasticsearch-template] to complete. Retrying every [1 second] (cause: [java.lang.Exception: 502 Bad Gateway: HttpEntity(application/json; charset=UTF-8,{"ok":false,"message":"The requested cluster is currently unavailable"})]) {}  
> [2018-11-23 13:12:43,354][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [apply-elasticsearch-template] to complete. Retrying every [1 second] (cause: [java.lang.Exception: 410 Gone: HttpEntity(application/json; charset=UTF-8,{"ok":false,"message":"Deleted cluster."})]) {}  
> [2018-11-23 13:22:16,460][ERROR][no.found.bootstrap.BootstrapInitial$] Unhandled error. {}  
> java.util.concurrent.TimeoutException: Futures timed out after [600000 milliseconds]  
> at scala.concurrent.impl.Promise$DefaultPromise.ready(Promise.scala:223)  
> at scala.concurrent.impl.Promise$DefaultPromise.result(Promise.scala:227)  
> at scala.concurrent.Await$$anonfun$result$1.apply(package.scala:190)  
> at scala.concurrent.BlockContext$DefaultBlockContext$.blockOn(BlockContext.scala:53)  
> at scala.concurrent.Await$.result(package.scala:190)  
> at no.found.bootstrap.BootstrapInitial.bootstrapServiceLayer(BootstrapInitial.scala:963)  
> at no.found.bootstrap.BootstrapInitial.bootstrap(BootstrapInitial.scala:678)  
> at no.found.bootstrap.BootstrapInitial$.delayedEndpoint$no$found$bootstrap$BootstrapInitial$1(BootstrapInitial.scala:1311)  
> at no.found.bootstrap.BootstrapInitial$delayedInit$body.apply(BootstrapInitial.scala:1305)  
> at scala.Function0$class.apply$mcV$sp(Function0.scala:34)  
> at scala.runtime.AbstractFunction0.apply$mcV$sp(AbstractFunction0.scala:12)  
> at scala.App$$anonfun$main$1.apply(App.scala:76)  
> at scala.App$$anonfun$main$1.apply(App.scala:76)  
> at scala.collection.immutable.List.foreach(List.scala:392)  
> at scala.collection.generic.TraversableForwarder$class.foreach(TraversableForwarder.scala:35)  
> at scala.App$class.main(App.scala:76)  
> at no.found.bootstrap.BootstrapInitial$.main(BootstrapInitial.scala:1305)  
> at no.found.bootstrap.BootstrapInitial.main(BootstrapInitial.scala)  
> [2018-11-23 13:22:16,510][INFO][no.found.bootstrap.ServiceLayerBootstrap] Waiting for [apply-elasticsearch-template] to complete. Retrying every [1 second] (cause: [akka.pattern.AskTimeoutException: Recipient[Actor[akka://default/user/IO-HTTP#-833220481]] had already been terminated. Sender[null] sent the message of type "spray.http.HttpRequest".]) {}

Thanks for your time.

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [November 26, 2018, 3:00pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/3 "2018-11-26T15:00:22Z")

</div>

Thanks for the report, that's a new one for me! We're looking into this now (we haven't had widespread reports on this, so I'm guessing "shooting from the hip" that it's an OS version incompatibility problem)

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [November 26, 2018, 6:05pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/4 "2018-11-26T18:05:38Z")

</div>

What Kernel version are you running? There does appear to be some reports of incompatibility vs some Centos 7 kernels

---

<div class="post-metadata">

**Author:** ![phimob](https://avatars.discourse-cdn.com/v4/letter/p/a3d4f5/32.png) [@phimob](https://discuss.elastic.co/u/phimob)\
**Post date:** [November 27, 2018, 12:07pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/5 "2018-11-27T12:07:55Z")

</div>

Hi, i'm running 4.4.162-1.el7.elrepo.x86\_64

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [November 27, 2018, 2:04pm UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/6 "2018-11-27T14:04:22Z")

</div>

I think this applies ([Limitations and known problems | Elastic Cloud Enterprise Reference [3.6] | Elastic](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-limitations.html)):

> - When you use OverlayFS with Kernel-LT 4.4.156 and later, there is a known regression that prevents Elastic Cloud Enterprise from completing the installation. From the kernel-archive, use Kernel 4.4.155.

See [Install Failing ECE 2.0.0 CentOS 7.5 - #5 by naknak987](https://discuss.elastic.co/t/install-failing-ece-2-0-0-centos-7-5/150600/5) for more details

---

<div class="post-metadata">

**Author:** ![phimob](https://avatars.discourse-cdn.com/v4/letter/p/a3d4f5/32.png) [@phimob](https://discuss.elastic.co/u/phimob)\
**Post date:** [November 28, 2018, 11:42am UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/7 "2018-11-28T11:42:51Z")

</div>

That was the problem, it's working now. Thank you very much!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2018, 11:43am UTC](https://discuss.elastic.co/t/ece-installation-failing-timeout/158028/8 "2018-12-12T11:43:05Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
