# ECE Installation Prerequisites - Max open files descriptors per process

**URL:** <https://discuss.elastic.co/t/ece-installation-prerequisites-max-open-files-descriptors-per-process/303325>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [April 26, 2022, 8:11pm UTC](https://discuss.elastic.co/t/ece-installation-prerequisites-max-open-files-descriptors-per-process/303325 "2022-04-26T20:11:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![morariu](https://avatars.discourse-cdn.com/v4/letter/m/0ea827/32.png) [@morariu](https://discuss.elastic.co/u/morariu)\
**Post date:** [April 26, 2022, 8:11pm UTC](https://discuss.elastic.co/t/ece-installation-prerequisites-max-open-files-descriptors-per-process/303325/1 "2022-04-26T20:11:31Z")

</div>

I am trying to install ECE but the prerequisites fail with the following:

`OS settings for max open file descriptors per process should be >= 65536, currently 32768`

That's what I get when I exec in the container and run "ulimit -n" however "cat /proc/sys/fs/file-max" shows 325000.

I have tried "DefaultLimitNOFILE=65536" in /etc/systemd/system.conf and /etc/systemd/user.conf but still failing.

Any suggestions on how to change this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 10, 2022, 8:12pm UTC](https://discuss.elastic.co/t/ece-installation-prerequisites-max-open-files-descriptors-per-process/303325/2 "2022-05-10T20:12:12Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
