# ECE Online Training

**URL:** <https://discuss.elastic.co/t/ece-online-training/196331>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [August 22, 2019, 1:30pm UTC](https://discuss.elastic.co/t/ece-online-training/196331 "2019-08-22T13:30:15Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sparcs07](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sparcs07/32/52825_2.png) [@sparcs07](https://discuss.elastic.co/u/sparcs07)\
**Post date:** [August 22, 2019, 1:30pm UTC](https://discuss.elastic.co/t/ece-online-training/196331/1 "2019-08-22T13:30:15Z")

</div>

Hi I am having issues with the ECE online training, where I have been told to post the issue here.

Step 17 , fails to work so I can not access kibana.  
I have rerun this process a few times.  
I note after restart sometimes the IP Address changes so maybe something in that.

Help .

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [August 22, 2019, 1:44pm UTC](https://discuss.elastic.co/t/ece-online-training/196331/2 "2019-08-22T13:44:19Z")

</div>

Hi @sparcs07

Can you link to the training you are doing? And for quickness give a quick outline of what step 17 is?

To your last point - i t is definitely the case that ECE installs require that the IP address be static - ECE will fail hard if it changes

Alex

---

<div class="post-metadata">

**Author:** ![sparcs07](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sparcs07/32/52825_2.png) [@sparcs07](https://discuss.elastic.co/u/sparcs07)\
**Post date:** [August 22, 2019, 3:51pm UTC](https://discuss.elastic.co/t/ece-online-training/196331/3 "2019-08-22T15:51:17Z")

</div>

> [@Alex\_Piggott](#):
>
> u link to the training you are doing? And for quickness give a quick outline of what step 17 is?

Hi  
An exercise shows us how to use Strigo to retrieve its Public IP Address  
Then go to Platform \> Settings  
And replace / update Deployment endpoints  
[172.31.28.54.ip.es.io](http://172.31.28.54.ip.es.io) :ip.es.io  
Save it

Then start Kibana

> Deployments . my\_cluster  
> Kibana \> Launch

Which fails to connect

Note: I have ECE in Production so just rpelaying learning from course and so awate of how to set endpoint

EROR see

ERROR Seen :

# This site can’t be reached

**[90475d684a984324808573bc1f15b807.172.31.28.54.ip.es.io](http://90475d684a984324808573bc1f15b807.172.31.28.54.ip.es.io)** took too long to respond.

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [August 27, 2019, 6:34pm UTC](https://discuss.elastic.co/t/ece-online-training/196331/4 "2019-08-27T18:34:28Z")

</div>

Thanks for the extra info!

Quick background on what's supposed to be happening here ... any ECE host with the proxy role listens on port 9243. Assuming it's hostname or IP is HOST\_OR\_IP then the DNS name `CLUSTERID.HOST_OR_IP.ip.es.io` just resolves to `HOST_OR_IP`.

So the error `90475d684a984324808573bc1f15b807.172.31.28.54.ip.es.io` means that the browser couldn't connect to `172.31.28.54`, which could mean that the port in question (`9243` or `443`) is firewalled off from the browser, or some other connectivity issue in your network

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 10, 2019, 6:34pm UTC](https://discuss.elastic.co/t/ece-online-training/196331/5 "2019-09-10T18:34:56Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
