# ECE - Unable to use base\_path in snapshot repository configuration

**URL:** <https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [January 20, 2018, 1:38am UTC](https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316 "2018-01-20T01:38:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![benb](https://avatars.discourse-cdn.com/v4/letter/b/e9c0ed/32.png) [@benb](https://discuss.elastic.co/u/benb)\
**Post date:** [January 20, 2018, 1:38am UTC](https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316/1 "2018-01-20T01:38:19Z")

</div>

When attempting to configure an S3 snapshot repository in ECE I'm unable to specify a base\_path like:

```
{
    "type": "s3",
    "settings": {
        "bucket": "backups",
        "base_path": "ece"
    }
}

```

When attempting this with an IAM role configured to only allow access to the ece directory it fails with the following error:

```
Unexpected error during step: [ensure-repository]: [
java.lang.Exception: Unable to ensure existence of snapshot repository: [
HttpResponse(500 Internal Server Error, HttpEntity(application/json; charset=UTF-8,
{
    "error":{
        "root_cause":[
            {
                "type":"repository_verification_exception",
                "reason":"[found-snapshots] path [snapshots/00000000000000000000000000000000] is not accessible on master node"
            }
        ],
        "type":"repository_verification_exception",
        "reason":"[found-snapshots] path [snapshots/00000000000000000000000000000000] is not accessible on master node",
        "caused_by":{
            "type":"i_o_exception",
            "reason":"Unable to upload object [snapshots/00000000000000000000000000000000/tests-0000000000000000000000/master.dat-temp] usi...),List(Warning: 299 Elasticsearch-5.6.5-6a37571 "[repositories.s3.buffer_size] setting was deprecated in Elasticsearch and will be removed in a future release! See the breaking changes documentation for the next major version." "Thu, 18 Jan 2018 00:00:00 GMT", Content-Type: application/json; charset=UTF-8, Content-Length: 800),HTTP/1.1)
]]

```

When giving the ECE instances full access to the bucket, everything works, but the snapshots end up in `snapshots/`, not `ece/snapshots/`.

This is the output of `_snapshot` of the cluster itself:

```
{"found-snapshots":{"type":"s3","settings":{"bucket":"backups","base_path":"snapshots/00000000000000000000000000000000"}}}

```

Is this just not supported in ECE yet?

---

<div class="post-metadata">

**Author:** ![thiago](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thiago/32/32096_2.png) [@thiago](https://discuss.elastic.co/u/thiago)\
**Post date:** [January 22, 2018, 2:22am UTC](https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316/2 "2018-01-22T02:22:37Z")

</div>

Yes, you can narrow down the permissions with an IAM Role. Please refer to this [https://www.elastic.co/guide/en/elasticsearch/plugins/6.1/repository-s3-repository.html](https://www.elastic.co/guide/en/elasticsearch/plugins/6.1/repository-s3-repository.html)

---

<div class="post-metadata">

**Author:** ![benb](https://avatars.discourse-cdn.com/v4/letter/b/e9c0ed/32.png) [@benb](https://discuss.elastic.co/u/benb)\
**Post date:** [January 30, 2018, 5:03pm UTC](https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316/3 "2018-01-30T17:03:03Z")

</div>

I originally followed those exact steps and got the errors I listed above when attempting to place the snapshots in a directory.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 27, 2018, 5:03pm UTC](https://discuss.elastic.co/t/ece-unable-to-use-base-path-in-snapshot-repository-configuration/116316/4 "2018-02-27T17:03:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
