# ECK - Fleet Server agent startup failure

**URL:** <https://discuss.elastic.co/t/eck-fleet-server-agent-startup-failure/280573>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [August 5, 2021, 5:55pm UTC](https://discuss.elastic.co/t/eck-fleet-server-agent-startup-failure/280573 "2021-08-05T17:55:42Z")\
**Posts on this page:** 1\
**Showing post:** 11

<div class="post-metadata">

**Author:** ![dkow](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkow/32/47340_2.png) [@dkow](https://discuss.elastic.co/u/dkow)\
**Post date:** [September 2, 2021, 10:29am UTC](https://discuss.elastic.co/t/eck-fleet-server-agent-startup-failure/280573/11 "2021-09-02T10:29:05Z")

</div>

Thanks everyone for your input.

This is caused by a bug in ECK Agent controller. See the [other thread](https://discuss.elastic.co/t/eck-fleet-startup-failure-on-eck-on-cloud/281700/10) for more details.

Thanks,  
David

---

_[View the full topic](https://discuss.elastic.co/t/eck-fleet-server-agent-startup-failure/280573)._
