# ECK on AKS - Error after upgrading k8s from V1.18 to V1.19

**URL:** <https://discuss.elastic.co/t/eck-on-aks-error-after-upgrading-k8s-from-v1-18-to-v1-19/267948>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [March 22, 2021, 7:00am UTC](https://discuss.elastic.co/t/eck-on-aks-error-after-upgrading-k8s-from-v1-18-to-v1-19/267948 "2021-03-22T07:00:52Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![HadarPeeran](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hadarpeeran/32/46926_2.png) [@HadarPeeran](https://discuss.elastic.co/u/HadarPeeran)\
**Post date:** [March 22, 2021, 7:00am UTC](https://discuss.elastic.co/t/eck-on-aks-error-after-upgrading-k8s-from-v1-18-to-v1-19/267948/1 "2021-03-22T07:00:52Z")

</div>

I have installed the operator by helm:

`helm install elastic-operator elastic/eck-operator -n elastic-system --create-namespace --version 1.4.0`

And Elastic node by:

> ```
> apiVersion: elasticsearch.k8s.elastic.co/v1
> kind: Elasticsearch
> metadata:
> name: quickstart
> spec:
> version: 7.11.2
> nodeSets:
> - name: default
> count: 1
> config:
> node.store.allow_mmap: false
> 
> ```

and I am getting below error:

> ```
> stacktrace": ["org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to resolve publish address]; nested: UnknownHostException[quickstart-es-default-0.quickstart-es-default.default.svc: Name or service not known];",
> "at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:174) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "Caused by: org.elasticsearch.transport.BindTransportException: Failed to resolve publish address",
> "at org.elasticsearch.http.AbstractHttpServerTransport.bindServer(AbstractHttpServerTransport.java:156) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.http.netty4.Netty4HttpServerTransport.doStart(Netty4HttpServerTransport.java:242) ~[?:?]",
> "at org.elasticsearch.xpack.security.transport.netty4.SecurityNetty4HttpServerTransport.doStart(SecurityNetty4HttpServerTransport.java:66) ~[?:?]",
> "at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:59) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.node.Node.start(Node.java:891) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "... 6 more",
> "Caused by: java.net.UnknownHostException: quickstart-es-default-0.quickstart-es-default.default.svc: Name or service not known",
> "at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method) ~[?:?]",
> "at java.net.InetAddress$PlatformNameService.lookupAllHostAddr(InetAddress.java:932) ~[?:?]",
> "at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1517) ~[?:?]",
> "at java.net.InetAddress$NameServiceAddresses.get(InetAddress.java:851) ~[?:?]",
> "at java.net.InetAddress.getAllByName0(InetAddress.java:1507) ~[?:?]",
> "at java.net.InetAddress.getAllByName(InetAddress.java:1366) ~[?:?]",
> "at java.net.InetAddress.getAllByName(InetAddress.java:1300) ~[?:?]",
> "at org.elasticsearch.common.network.NetworkService.resolveInternal(NetworkService.java:248) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.common.network.NetworkService.resolveInetAddresses(NetworkService.java:198) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.common.network.NetworkService.resolvePublishHostAddresses(NetworkService.java:154) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.http.AbstractHttpServerTransport.bindServer(AbstractHttpServerTransport.java:154) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.http.netty4.Netty4HttpServerTransport.doStart(Netty4HttpServerTransport.java:242) ~[?:?]",
> "at org.elasticsearch.xpack.security.transport.netty4.SecurityNetty4HttpServerTransport.doStart(SecurityNetty4HttpServerTransport.java:66) ~[?:?]",
> "at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:59) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.node.Node.start(Node.java:891) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.10.2.jar:7.10.2]",
> "... 6 more"] }
> uncaught exception in thread [main]
> BindTransportException[Failed to resolve publish address]; nested: UnknownHostException[quickstart-es-default-0.quickstart-es-default.default.svc: Name or service not known];
> Likely root cause: java.net.UnknownHostException: quickstart-es-default-0.quickstart-es-default.default.svc: Name or service not known
> at java.base/java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
> at java.base/java.net.InetAddress$PlatformNameService.lookupAllHostAddr(InetAddress.java:932)
> at java.base/java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1517)
> at java.base/java.net.InetAddress$NameServiceAddresses.get(InetAddress.java:851)
> at java.base/java.net.InetAddress.getAllByName0(InetAddress.java:1507)
> at java.base/java.net.InetAddress.getAllByName(InetAddress.java:1366)
> at java.base/java.net.InetAddress.getAllByName(InetAddress.java:1300)
> at org.elasticsearch.common.network.NetworkService.resolveInternal(NetworkService.java:248)
> at org.elasticsearch.common.network.NetworkService.resolveInetAddresses(NetworkService.java:198)
> at org.elasticsearch.common.network.NetworkService.resolvePublishHostAddresses(NetworkService.java:154)
> at org.elasticsearch.http.AbstractHttpServerTransport.bindServer(AbstractHttpServerTransport.java:154)
> at org.elasticsearch.http.netty4.Netty4HttpServerTransport.doStart(Netty4HttpServerTransport.java:242)
> at org.elasticsearch.xpack.security.transport.netty4.SecurityNetty4HttpServerTransport.doStart(SecurityNetty4HttpServerTransport.java:66)
> at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:59)
> at org.elasticsearch.node.Node.start(Node.java:891)
> at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317)
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402)
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170)
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
> at org.elasticsearch.cli.Command.main(Command.java:90)
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
> 
> ```

Same worked perfect on Aks with k8s 1.18, after upgrade to k8s 1.19 I got above error

Can you please help ?  
thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 19, 2021, 7:01am UTC](https://discuss.elastic.co/t/eck-on-aks-error-after-upgrading-k8s-from-v1-18-to-v1-19/267948/2 "2021-04-19T07:01:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
