# Eck - operator error log with enterprise search v1

**URL:** <https://discuss.elastic.co/t/eck-operator-error-log-with-enterprise-search-v1/356800>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [April 4, 2024, 4:31pm UTC](https://discuss.elastic.co/t/eck-operator-error-log-with-enterprise-search-v1/356800 "2024-04-04T16:31:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cristian\_Pereyra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cristian_pereyra/32/126779_2.png) [@Cristian\_Pereyra](https://discuss.elastic.co/u/Cristian_Pereyra)\
**Post date:** [April 4, 2024, 4:31pm UTC](https://discuss.elastic.co/t/eck-operator-error-log-with-enterprise-search-v1/356800/1 "2024-04-04T16:31:07Z")

</div>

Hello everyone! I hope you are doing well.

I am receiving the error log from the ECK operator:

jsonCopy code

```bash
{
  "log.level": "error",
  "@timestamp": "2024-04-04T16:08:48.819Z",
  "log.logger": "resource-reporter",
  "message": "Failed to report licensing information",
  "service.version": "2.11.1+ddde9953",
  "service.type": "eck",
  "ecs.version": "1.4.0",
  "error": "failed to aggregate Enterprise Search memory: failed to get API group resources: unable to retrieve the complete list of server APIs: enterprisesearch.k8s.elastic.co/v1: the server could not find the requested resource",
  "errorVerbose": "failed to get API group resources: unable to retrieve the complete list of server APIs: enterprisesearch.k8s.elastic.co/v1: the server could not find the requested resource\nfailed to aggregate Enterprise Search memory\ngithub.com/elastic/cloud-on-k8s/v2/pkg/license.Aggregator.aggregateEnterpriseSearchMemory\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/aggregator.go:91\ngithub.com/elastic/cloud-on-k8s/v2/pkg/license.Aggregator.AggregateMemory\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/aggregator.go:48\ngithub.com/elastic/cloud-on-k8s/v2/pkg/license.ResourceReporter.Get\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/reporter.go:80\ngithub.com/elastic/cloud-on-k8s/v2/pkg/license.ResourceReporter.Report\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/reporter.go:67\ngithub.com/elastic/cloud-on-k8s/v2/pkg/license.ResourceReporter.Start\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/reporter.go:48\ngithub.com/elastic/cloud-on-k8s/v2/cmd/manager.asyncTasks.func1\n\t/go/src/github.com/elastic/cloud-on-k8s/cmd/manager/main.go:781\nruntime.goexit\n\t/usr/local/go/src/runtime/asm_amd64.s:1650",
  "error.stack_trace": "github.com/elastic/cloud-on-k8s/v2/pkg/license.ResourceReporter.Start\n\t/go/src/github.com/elastic/cloud-on-k8s/pkg/license/reporter.go:50\ngithub.com/elastic/cloud-on-k8s/v2/cmd/manager.asyncTasks.func1\n\t/go/src/github.com/elastic/cloud-on-k8s/cmd/manager/main.go:781"
}

```

Clearly, the error is `enterprisesearch.k8s.elastic.co/v1: the server could not find the requested resource`.

I read this thread [link](https://discuss.elastic.co/t/eck-operator-1-4-stuck-in-deployment-error-no-matches-for-kind-enterprisesearch-in-version-enterpriseseach-k8s-elastic-co-v1/271818) which helped me understand that the version v1 of enterprise search was not declared, only v1beta1 was.

In my case, the `crd.yaml` file does contain the version v1 as well as the version v1beta1.

So, ¿why is the error mentioned by the operator occurring?

Elasticsearch and Kibana were deployed and functioning. I mention this for context.

To apply the CRD and the operator, I used [this guide](https://www.elastic.co/guide/en/cloud-on-k8s/2.11/k8s-deploy-eck.html) with the operator version 2.11.1 and CRD version 2.11.1.

This is my first time using ECK. Thank you very much.

---

<div class="post-metadata">

**Author:** ![Cristian\_Pereyra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cristian_pereyra/32/126779_2.png) [@Cristian\_Pereyra](https://discuss.elastic.co/u/Cristian_Pereyra)\
**Post date:** [April 17, 2024, 6:32pm UTC](https://discuss.elastic.co/t/eck-operator-error-log-with-enterprise-search-v1/356800/2 "2024-04-17T18:32:47Z")

</div>

Solved. The operator was reinstalled
