# ECK Quickstart - Elasticsearch fails to start with "permission denied" error

**URL:** <https://discuss.elastic.co/t/eck-quickstart-elasticsearch-fails-to-start-with-permission-denied-error/247094>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [September 1, 2020, 12:53pm UTC](https://discuss.elastic.co/t/eck-quickstart-elasticsearch-fails-to-start-with-permission-denied-error/247094 "2020-09-01T12:53:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![kurbar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kurbar/32/74880_2.png) [@kurbar](https://discuss.elastic.co/u/kurbar)\
**Post date:** [September 1, 2020, 12:53pm UTC](https://discuss.elastic.co/t/eck-quickstart-elasticsearch-fails-to-start-with-permission-denied-error/247094/1 "2020-09-01T12:53:32Z")

</div>

Hello, I’m following the quickstart guide for ECK on one of my Kubeadm clusters (Kubernetes version 1.15.7). I have the Elastic operator up and running with version 1.2.1. I then tried deploying the same Elasticsearch cluster as in the quickstart. However, it does not want to come up:  
`chroot: failed to run command '/usr/share/elasticsearch/bin/elasticsearch': Permission denied`

I have issued a 2 GB persistent volume through Gluster. The `elastic-internal-init-filesystem` init container seems to run successfully as well.

My manifest file looks like this:

```auto
apiVersion: elasticsearch.k8s.elastic.co/v1
kind: Elasticsearch
metadata:
  name: monitoring
  namespace: <redacted>
spec:
  version: 7.9.0
  nodeSets:
  - name: default
    count: 1
    volumeClaimTemplates:
    - metadata:
        name: elasticsearch-data
      spec:
        accessModes:
        - ReadWriteOnce
        resources:
          requests:
            storage: 2Gi
        storageClassName: standard
    config:
      node.master: true
      node.data: true
      node.ingest: true
      node.store.allow_mmap: false

```

I tried looking for any possible securityContext configurations but couldn't find any. Am I missing something?

---

<div class="post-metadata">

**Author:** ![sebgl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sebgl/32/48702_2.png) [@sebgl](https://discuss.elastic.co/u/sebgl)\
**Post date:** [September 4, 2020, 12:30pm UTC](https://discuss.elastic.co/t/eck-quickstart-elasticsearch-fails-to-start-with-permission-denied-error/247094/2 "2020-09-04T12:30:22Z")

</div>

Duplicate Github issue: [https://github.com/elastic/cloud-on-k8s/issues/3701](https://github.com/elastic/cloud-on-k8s/issues/3701)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 8:12am UTC](https://discuss.elastic.co/t/eck-quickstart-elasticsearch-fails-to-start-with-permission-denied-error/247094/3 "2022-11-04T08:12:07Z")

</div>


