# ECK showInSelector causes infinite 302 and kibana pod fails

**URL:** <https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [April 27, 2021, 6:44am UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321 "2021-04-27T06:44:25Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ewolfman](https://avatars.discourse-cdn.com/v4/letter/e/5f8ce5/32.png) [@ewolfman](https://discuss.elastic.co/u/ewolfman)\
**Post date:** [April 27, 2021, 6:44am UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321/1 "2021-04-27T06:44:25Z")

</div>

Hi,

Kibana 7.10.2.  
My goal is to either completely hide the provider selector screen or hide the providers.

When settings xpack [showInSelector](https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html#authentication-provider-settings) to 'false', Kibana pod fails to load with what looks like an infinite loop of GET that results with 302.

Here's my config:

```auto
    xpack:
      security:
        authc:
          providers:
            oidc:
              mytest:
                description: abc
                order: 1
                realm: realm1
                showInSelector: false <== problem 1

```

Same behavior happens when setting the [xpack.security.authc.selector.enabled](https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html#login-ui-settings) to disabled:

```auto
    xpack:
      security:
        authc:
          providers:
            oidc:
              mytest:
                description: abc
                order: 1
                realm: realm1
          selector:
            enabled: false <== problem 2

```

What could be the reason for this and how can I troubleshoot it?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 27, 2021, 7:24am UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321/2 "2021-04-27T07:24:13Z")

</div>

> [@ewolfman](#):
>
> Kibana pod fails to load with what looks like an infinite loop of GET that results with 302.

What do the logs show?

---

<div class="post-metadata">

**Author:** ![ewolfman](https://avatars.discourse-cdn.com/v4/letter/e/5f8ce5/32.png) [@ewolfman](https://discuss.elastic.co/u/ewolfman)\
**Post date:** [April 27, 2021, 7:57am UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321/3 "2021-04-27T07:57:16Z")

</div>

> [@ewolfman](#):
>
> ```auto
> selector:
> enabled: false
> 
> ```

I masked sensitive info:

> {"type":"response","@timestamp":"2021-04-27T07:52:47Z","tags":,"pid":7,"method":"get","statusCode":302,"req":{"url":"/kibana/internal/security/capture-url?next=%2Fkibana%2Fkibana%2Finternal%2Fsecurity%2Fcapture-url%3Fnext%3D%252Fkibana%252Flogin%26providerType%3Doidc%26providerName%3D\*\*\*&providerType=oidc&providerName=_**","method":"get","headers":{"host":"10.58.160.44:5601","user-agent":"kube-probe/1.18","referer":"[https://10.58.160.44:5601/kibana/internal/security/capture-url?next=%2Fkibana%2Flogin&providerType=oidc&providerName=\*\*\*","accept-encoding":"gzip","connection":"close"},"remoteAddress":"10.58.160.35","userAgent":"kube-probe/1.18","referer":"https://10.58.160.44:5601/kibana/internal/security/capture-url?next=%2Fkibana%2Flogin&providerType=oidc&providerName=\*\*\*"},"res":{"statusCode":302,"responseTime":2,"contentLength":9},"message":"GET](https://10.58.160.44:5601/kibana/internal/security/capture-url?next=%2Fkibana%2Flogin&providerType=oidc&providerName=***%22,%22accept-encoding%22:%22gzip%22,%22connection%22:%22close%22%7D,%22remoteAddress%22:%2210.58.160.35%22,%22userAgent%22:%22kube-probe/1.18%22,%22referer%22:%22https://10.58.160.44:5601/kibana/internal/security/capture-url?next=%2Fkibana%2Flogin&providerType=oidc&providerName=***%22%7D,%22res%22:%7B%22statusCode%22:302,%22responseTime%22:2,%22contentLength%22:9%7D,%22message%22:%22GET) /kibana/internal/security/capture-url?next=%2Fkibana%2Fkibana%2Finternal%2Fsecurity%2Fcapture-url%3Fnext%3D%252Fkibana%252Flogin%26providerType%3Doidc%26providerName%3D**_&providerType=oidc&providerName=\*\*\* 302 2ms - 9.0B"}

---

<div class="post-metadata">

**Author:** ![ewolfman](https://avatars.discourse-cdn.com/v4/letter/e/5f8ce5/32.png) [@ewolfman](https://discuss.elastic.co/u/ewolfman)\
**Post date:** [April 27, 2021, 6:07pm UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321/4 "2021-04-27T18:07:29Z")

</div>

hi @warkolm any idea?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 25, 2021, 6:07pm UTC](https://discuss.elastic.co/t/eck-showinselector-causes-infinite-302-and-kibana-pod-fails/271321/5 "2021-05-25T18:07:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
