# \[eck-stack\] Unable to gather kubernetes logs via agent while passing ELASTICSEARCH\_CA to agent

**URL:** <https://discuss.elastic.co/t/eck-stack-unable-to-gather-kubernetes-logs-via-agent-while-passing-elasticsearch-ca-to-agent/349198>\
**Category:** Elastic Agent\
**Created:** [December 12, 2023, 10:08pm UTC](https://discuss.elastic.co/t/eck-stack-unable-to-gather-kubernetes-logs-via-agent-while-passing-elasticsearch-ca-to-agent/349198 "2023-12-12T22:08:56Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![sevaho](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sevaho/32/129826_2.png) [@sevaho](https://discuss.elastic.co/u/sevaho)\
**Post date:** [December 13, 2023, 2:59pm UTC](https://discuss.elastic.co/t/eck-stack-unable-to-gather-kubernetes-logs-via-agent-while-passing-elasticsearch-ca-to-agent/349198/2 "2023-12-13T14:59:53Z")

</div>

I notice that I am not alone with the issue ([Beats in elastic-agent reporting "failed to connect to backoff" - #5 by trudyc](https://discuss.elastic.co/t/beats-in-elastic-agent-reporting-failed-to-connect-to-backoff/299506/5))

I am trying to find the correct way to specify it in the helm values, but the documentation is not quite clear where to put it, I am looking at [https://github.com/elastic/cloud-on-k8s/blob/main/deploy/eck-stack/charts/eck-fleet-server/values.yaml](https://github.com/elastic/cloud-on-k8s/blob/main/deploy/eck-stack/charts/eck-fleet-server/values.yaml) but cannot seem to find any `ssl.certificate_authorities` key to write it to...

---

_[View the full topic](https://discuss.elastic.co/t/eck-stack-unable-to-gather-kubernetes-logs-via-agent-while-passing-elasticsearch-ca-to-agent/349198)._
