# Elasti Search failed to connect local host port:9200

**URL:** <https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958>\
**Category:** Elasticsearch\
**Created:** [November 28, 2022, 2:38pm UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958 "2022-11-28T14:38:49Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Naga\_rajan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/naga_rajan/32/100760_2.png) [@Naga\_rajan](https://discuss.elastic.co/u/Naga_rajan)\
**Post date:** [November 28, 2022, 2:38pm UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/1 "2022-11-28T14:38:49Z")

</div>

Hi Everyone,  
I Installed eck-operator, elasticsearch and kibana using this chart - [[helm-charts/elasticsearch at main · elastic/helm-charts · GitHub](https://github.com/elastic/helm-charts/tree/main/elasticsearch)] successfully deployed. kibana ui user page also coming. But while exposing the elasticsearch service through the port, It shows: **page not working**. Can anyone suggest me the solution.  
Kubernetes version: 1.23

Note: We are using ELK for logs.

 ![page not working](https://us1.discourse-cdn.com/elastic/original/3X/f/3/f3a4ebc12d546bd5ea38aa84e48c051351da97c2.png)

---

<div class="post-metadata">

**Author:** ![grumo35](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grumo35/32/59451_2.png) [@grumo35](https://discuss.elastic.co/u/grumo35)\
**Post date:** [November 28, 2022, 5:10pm UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/2 "2022-11-28T17:10:00Z")

</div>

Hi,

try https://

Can you show the server listening ports ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 29, 2022, 2:13am UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/3 "2022-11-29T02:13:30Z")

</div>

Welcome to our community! 😃

What do the Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![Naga\_rajan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/naga_rajan/32/100760_2.png) [@Naga\_rajan](https://discuss.elastic.co/u/Naga_rajan)\
**Post date:** [November 30, 2022, 6:09am UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/4 "2022-11-30T06:09:39Z")

</div>

Thanks man it works.

---

<div class="post-metadata">

**Author:** ![Naga\_rajan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/naga_rajan/32/100760_2.png) [@Naga\_rajan](https://discuss.elastic.co/u/Naga_rajan)\
**Post date:** [November 30, 2022, 6:23am UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/5 "2022-11-30T06:23:22Z")

</div>

I deployed filebeat as sidecar in our micro service helm chart, in that yaml I mentioned elasticsearch host, username, password and kibana host also. But when I use the kibana UI it asking to add integration.

 ![kibana home page](https://us1.discourse-cdn.com/elastic/original/3X/1/9/1947696a9fd9de69a1abf333a82f8b2dde944ed7.png)  
In this I clciked elasticsearch logs, because filebeat transfer the var/log path from our componenet to elasticsearch thats what I clicked elasticsearch logs.

 ![elasticsearch logs](https://us1.discourse-cdn.com/elastic/original/3X/b/2/b2a74bf77deb5baa9086e7b52fc1a9ee814f463e.png)  
then again asking to add filebeat. I don't know about this. can u guide me what is integration and how can i get our componenet logs to kibana.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 28, 2022, 6:24am UTC](https://discuss.elastic.co/t/elasti-search-failed-to-connect-local-host-port-9200/319958/6 "2022-12-28T06:24:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
