# Elastic 6.4.2 will not start "unable to load JNA native support library"

**URL:** https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360
**Category:** Elasticsearch
**Created:** [October 29, 2018, 1:42am UTC](https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360 "2018-10-29T01:42:49Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Jose\_Ramierez](https://avatars.discourse-cdn.com/v4/letter/j/4bbf92/32.png) [@Jose\_Ramierez](https://discuss.elastic.co/u/Jose_Ramierez)
#### Post date: [October 29, 2018, 1:42am UTC](https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360/1 "2018-10-29T01:42:50Z")

</div>

I have installed ES soooo many times. Every once in awhile, something new pops up.

CentOS 7  
Elastic 6.4.2 from RPM installer

I had it running, but we then needed to go into recovery mode to resize the root file system.

And now ES won't start, error in log is:

```
[2018-10-28T19:53:00,873][WARN][o.e.b.Natives] unable to loa
d JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch.PRdXLpjT/jna--19853545
63/jna2901201660730912229.tmp: /tmp/elasticsearch.PRdXLpjT/jna--198535456
3/jna2901201660730912229.tmp: failed to map segment from shared object: O
peration not permitted
        at java.lang.ClassLoader

```

I see that ls -l on /tmp is:

```
$ ls -l /tmp
total 52
drwx------. 2 root root 4096 Oct 26 11:55 elasticsearch.QbzXEIeS

```

What is the step to resolve?

---

<div class="post-metadata">

### Author: ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)
#### Post date: [October 29, 2018, 4:09pm UTC](https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360/2 "2018-10-29T16:09:46Z")

</div>

Have you changed `/tmp` to be mounted `noexec`? This looks similar to [https://github.com/elastic/elasticsearch/issues/18406](https://github.com/elastic/elasticsearch/issues/18406). You can change the tmp dir Jna uses with `-Djna.tmpdir` in your `jvm.options` or with `ES_JAVA_OPTS` env var.

---

<div class="post-metadata">

### Author: ![Jose\_Ramierez](https://avatars.discourse-cdn.com/v4/letter/j/4bbf92/32.png) [@Jose\_Ramierez](https://discuss.elastic.co/u/Jose_Ramierez)
#### Post date: [October 29, 2018, 8:03pm UTC](https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360/3 "2018-10-29T20:03:28Z")

</div>

That was in fact the issue.

Now solved.

Thank you!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 26, 2018, 8:15pm UTC](https://discuss.elastic.co/t/elastic-6-4-2-will-not-start-unable-to-load-jna-native-support-library/154360/4 "2018-11-26T20:15:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
