# Elastic 6.6.0: Windows server 2016 service not starting

**URL:** <https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283>\
**Category:** Elasticsearch\
**Created:** [March 14, 2019, 9:17am UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283 "2019-03-14T09:17:23Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sheppie](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@Sheppie](https://discuss.elastic.co/u/Sheppie)\
**Post date:** [March 14, 2019, 9:17am UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283/1 "2019-03-14T09:17:23Z")

</div>

The topic has been discussed earlier [here](https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783) and [here](https://discuss.elastic.co/t/elastic-search-msi-on-server-2016-service-cant-start/102257) about not being able to start the ElasticSearch service under a Domain Service account.

I know the account does not have sufficient privileges "somewhere", but I'm having trouble pinpointing the exact permission. When I assign Administrator rights to the account, it works.

I've given the following permissions within the user rights assignment:  
Allow log on as a service  
Allow log on as a batch job

I've given the following permission on the folders:  
Install folder: Read only  
Log folder: Modify  
Data folder: Modify  
Config folder: Modify

Additionally, there are several GPO rules in place for default domain servers, but i don't think that there is a problem there. On another server, Windows 2008R2, the service is staring under the same account and does not have full administrator rights on that server.

So my question: What permissions does the domain service account need to have to be able to run the service, without adding the account to the Administrators Group.

The windows eventlog error:  
Source: .NET Runtime, ID 1026  
Application: elasticsearch.exe  
Framework Version: v4.0.30319  
Description: The process was terminated due to an unhandled exception.  
Exception Info: Elastic.ProcessHosts.Process.StartupException  
at Elastic.ProcessHosts.Process.ProcessBase.HandleException(System.Exception)  
at System.Reactive.ObserverBase`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at System.Reactive.Observer`1[[System.\_\_Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception)  
at System.Reactive.Linq.ObservableImpl.AsObservable`1+_[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at System.Reactive.AutoDetachObserver`1[[System.\_\_Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnErrorCore(System.Exception)  
at System.Reactive.ObserverBase`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at Elastic.ProcessHosts.Process.ObservableProcess+<>c__DisplayClass22_0.<CreateProcessExitSubscription>b__0(System.Reactive.EventPattern`1\<System.Object\>)  
at System.Reactive.AnonymousSafeObserver`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnNext(System.__Canon) at System.EventHandler.Invoke(System.Object, System.EventArgs) at System.Diagnostics.Process.OnExited() at System.Diagnostics.Process.RaiseOnExited() at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading._ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(System.Object, Boolean)`

Eventlog error 2  
Source: Application Error, EventID 1000

Faulting application name: elasticsearch.exe, version: 6.6.0.0, time stamp: 0x5c49ae87  
Faulting module name: KERNELBASE.dll, version: 10.0.14393.2791, time stamp: 0x5c5a4180  
Exception code: 0xe0434352  
Fault offset: 0x0000000000034078  
Faulting process id: 0x2208  
Faulting application start time: 0x01d4d9a985c88f9a  
Faulting application path: `omitted`  
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll  
Report Id: 91a96679-3eff-498d-8c04-ec17895cb081  
Faulting package full name:  
Faulting package-relative application ID:

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [March 22, 2019, 10:49am UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283/2 "2019-03-22T10:49:48Z")

</div>

> [@Sheppie](#):
>
> Install folder: Read only  
> Log folder: Modify  
> Data folder: Modify  
> Config folder: Modify

Have you tried with `Modify` NTFS permissions on the Install folder too?

Another angle to investigate this is to start the elasticsearch.exe on the command line and see if it starts or fails to start. If the latter, would you be able to share the exception message and stack traces?

---

<div class="post-metadata">

**Author:** ![Sheppie](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@Sheppie](https://discuss.elastic.co/u/Sheppie)\
**Post date:** [March 27, 2019, 3:21pm UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283/3 "2019-03-27T15:21:33Z")

</div>

After I've added the modify permissions, the service won't start under the service account.

I'm currently trying to get that same account additional rights to log on locally so that I can run an interactive CMD prompt and check if there is an exception message there.

---

<div class="post-metadata">

**Author:** ![Sheppie](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@Sheppie](https://discuss.elastic.co/u/Sheppie)\
**Post date:** [April 10, 2019, 7:10am UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283/4 "2019-04-10T07:10:47Z")

</div>

Ok, so i've fixed this issue and it was indeed a permission issue. The problem was that the service account didn't had the right permissions on the disk itself. So the I configured read/folder traverse permissions on the root of the disk and from there on read/write as mentioned above and the service started successfully.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2019, 7:10am UTC](https://discuss.elastic.co/t/elastic-6-6-0-windows-server-2016-service-not-starting/172283/5 "2019-05-08T07:10:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
