# Elastic 7.10.0 on ubuntu 20 : error NoSuchFileException: /etc/elasticsearch/jvm.options

**URL:** https://discuss.elastic.co/t/elastic-7-10-0-on-ubuntu-20-error-nosuchfileexception-etc-elasticsearch-jvm-options/255415
**Category:** Discussions en français
**Created:** [November 14, 2020, 7:38pm UTC](https://discuss.elastic.co/t/elastic-7-10-0-on-ubuntu-20-error-nosuchfileexception-etc-elasticsearch-jvm-options/255415 "2020-11-14T19:38:30Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![ysimonx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ysimonx/32/77623_2.png) [@ysimonx](https://discuss.elastic.co/u/ysimonx)
#### Post date: [November 14, 2020, 7:38pm UTC](https://discuss.elastic.co/t/elastic-7-10-0-on-ubuntu-20-error-nosuchfileexception-etc-elasticsearch-jvm-options/255415/1 "2020-11-14T19:38:30Z")

</div>

Je poste ce message au cas où ca peut aider d'autres qui sont dans mon cas :

J'ai mis à jour elastic search sur ubuntu 20

Il est passé de la version 7.9.x à la version 7.10

ElasticSearch n'a plus fonctionné, impossible de le relancer,  
j'ai tenté de le desinstaller et de le relancer .. bof ... rien

rien dans /var/log/elasticsearch, qui reste vide

avec journalctl -xe

j'obtiens

```auto
    -- Subject: L'unité (unit) elasticsearch.service a commencé à démarrer
    -- Defined-By: systemd
    -- Support: http://www.ubuntu.com/support
    -- 
    -- L'unité (unit) elasticsearch.service a commencé à démarrer.
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: Exception in thread "main" java.nio.file.NoSuchFileException: /etc/elasticsearch/jvm.options
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:218)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/java.nio.file.Files.newByteChannel(Files.java:375)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/java.nio.file.Files.newByteChannel(Files.java:426)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:420)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at java.base/java.nio.file.Files.newInputStream(Files.java:160)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at org.elasticsearch.tools.launchers.JvmOptionsParser.readJvmOptionsFiles(JvmOptionsParser.java:>
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:128)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd-entrypoint[16018]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:95)
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
    -- Subject: Unit process exited
    -- Defined-By: systemd
    -- Support: http://www.ubuntu.com/support
    -- 
    -- An ExecStart= process belonging to unit elasticsearch.service has exited.
    -- 
    -- The process' exit code is 'exited' and its exit status is 1.
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
    -- Subject: Unit failed
    -- Defined-By: systemd
    -- Support: http://www.ubuntu.com/support
    -- 
    -- The unit elasticsearch.service has entered the 'failed' state with result 'exit-code'.
    nov. 14 19:46:56 ysimonx-NUC7CJYH systemd[1]: Failed to start Elasticsearch.
    -- Subject: L'unité (unit) elasticsearch.service a échoué
    -- Defined-By: systemd
    -- Support: http://www.ubuntu.com/support
    -- 
    -- L'unité (unit) elasticsearch.service a échoué, avec le résultat failed.

```

Je confirme que je n'ai aucun fichier "/etc/elasticsearch/jvm.options"

J'ai contourné ce soucis en portant, comme j'aurais du le faire, elastic search dans un container docker, en forcant la version 7.9.3

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 12, 2020, 7:38pm UTC](https://discuss.elastic.co/t/elastic-7-10-0-on-ubuntu-20-error-nosuchfileexception-etc-elasticsearch-jvm-options/255415/2 "2020-12-12T19:38:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
