# Elastic-agent-complete-\>x509: certificate signed by unknown authority

**URL:** <https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring, docker\
**Created:** [February 26, 2025, 12:03pm UTC](https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081 "2025-02-26T12:03:33Z")\
**Posts on this page:** 1\
**Showing post:** 7

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [February 28, 2025, 10:48am UTC](https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081/7 "2025-02-28T10:48:30Z")

</div>

So the issue is the certification configuration for Elastic Agent and Fleet, which Synthetic Monitoring uses. Until you fix the agent certificate issue the monitors will fail.

I did a quick scan of your configuration against the [SSL/TLS guide](https://www.elastic.co/guide/en/fleet/current/secure-connections.html) and I can't see any obvious misconfiguration.

I assume you are using a self-managed fleet server? I would recommend checking out the configuring TLS guide and also see if you need to specify the certs in Kibana as outline in [this similar issue](https://discuss.elastic.co/t/elastic-agent-error-dialing-x509-certificate-signed-by-unknown-authority/315675/5).

Alternatively you could see if regenerating the certifications is an option.

Can you try either of those and let us know if that resolves the issue?

---

_[View the full topic](https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081)._
