# Elastic Agent doesn't resolve nodename

**URL:** <https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010>\
**Category:** Metrics\
**Tags:** fleet\
**Created:** [March 17, 2025, 1:36pm UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010 "2025-03-17T13:36:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![vigen](https://avatars.discourse-cdn.com/v4/letter/v/91b2a8/32.png) [@vigen](https://discuss.elastic.co/u/vigen)\
**Post date:** [March 17, 2025, 1:36pm UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010/1 "2025-03-17T13:36:45Z")

</div>

I followed to [Example: Install Fleet-managed Elastic Agent on Kubernetes using Helm](https://www.elastic.co/guide/en/fleet/8.17/example-kubernetes-fleet-managed-agent-helm.html) guide and deployed elastic agents on my k8s cluster. But agents statuses are unhealthy, and logs shows the following error

```plaintext
Error fetching data for metricset kubernetes.volume: error doing HTTP request to fetch 'volume' Metricset data: error making http request: Get \"https://main-cluster-dev-default-b45be-bynlj:10250/stats/summary\": lookup main-cluster-dev-default-b45be-bynlj on 10.96.0.10:53: no such host

```

The problem is not available in the `main` branch of the [elastic-agent](https://github.com/elastic/elastic-agent), but guide suggests to use `8.16` branch.

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [April 2, 2025, 11:22am UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010/2 "2025-04-02T11:22:45Z")

</div>

Hey @vigen, welcome to discuss 🙂 and sorry for the late response!

> [@vigen](#):
>
> The problem is not available in the `main` branch of the [elastic-agent](https://github.com/elastic/elastic-agent), but guide suggests to use `8.16` branch.

Could you try using 8.17 instead of 8.16? We may need to update the docs.

---

<div class="post-metadata">

**Author:** ![vigen](https://avatars.discourse-cdn.com/v4/letter/v/91b2a8/32.png) [@vigen](https://discuss.elastic.co/u/vigen)\
**Post date:** [April 2, 2025, 12:11pm UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010/3 "2025-04-02T12:11:47Z")

</div>

Hi @jsoriano, thank you for your reply!

I'll check with version 8.17 and get back with results.

---

<div class="post-metadata">

**Author:** ![vigen](https://avatars.discourse-cdn.com/v4/letter/v/91b2a8/32.png) [@vigen](https://discuss.elastic.co/u/vigen)\
**Post date:** [May 2, 2025, 3:49pm UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010/4 "2025-05-02T15:49:24Z")

</div>

Tested with `v8.18.0`, the same result 😞

The agent tries to make a request to `https://NODE_NAME:10250/stats/summary` to fetch metrics. In our cluster, we're using CoreDNS with the Kubernetes plugin.  
But, I couldn’t find any documentation stating that `NODE_NAME` will be resolved automatically. Do you know what DNS setup is assumed or required by this setup?

---

<div class="post-metadata">

**Author:** ![erikg](https://avatars.discourse-cdn.com/v4/letter/e/91b2a8/32.png) [@erikg](https://discuss.elastic.co/u/erikg)\
**Post date:** [May 7, 2025, 6:48pm UTC](https://discuss.elastic.co/t/elastic-agent-doesnt-resolve-nodename/376010/5 "2025-05-07T18:48:01Z")

</div>

@vigen  
Perhaps look at this: [Kubernetes Integration - DNS Issue - Elastic Stack / Elastic Agent - Discuss the Elastic Stack](https://discuss.elastic.co/t/kubernetes-integration-dns-issue/376772) not using Helm but it identifies a workaround
